Bug Hunting Session
Bug 63927 - Export (HTML, DOC, DOCX): handles weak bidi characters as strong ones
Summary: Export (HTML, DOC, DOCX): handles weak bidi characters as strong ones
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL 93716
  Show dependency treegraph
 
Reported: 2013-04-25 16:04 UTC by Lior Kaplan
Modified: 2015-08-30 08:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
testdoc (11.48 KB, application/vnd.oasis.opendocument.text)
2013-04-25 16:06 UTC, Lior Kaplan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lior Kaplan 2013-04-25 16:04:25 UTC
Taking RTL text which has weak bidi characters like commas, brackets, hyphen, etc. and exporting it to HTML results in HTML code that separates the weak characters from the RTL text.

Text:
"בית משפט" - לרבות בית דין לעבודה, בית דין דתי, ראש הוצאה לפועל לפי חוק ההוצאה לפועל, תשכ"ז-1967 (להלן - חוק ההוצאה לפועל), ולמעט בית דין צבאי כמשמעותו בחוק השיפוט הצבאי, תשט"ו– 1955;

HTML export:
<P DIR="RTL" ALIGN=RIGHT STYLE="margin-bottom: 0cm">	&quot;<FONT FACE="Nachlieli CLM"><SPAN LANG="he-IL">בית
משפט</SPAN></FONT>&quot; - <FONT FACE="Nachlieli CLM"><SPAN LANG="he-IL">לרבות
בית דין לעבודה</SPAN></FONT>, <FONT FACE="Nachlieli CLM"><SPAN LANG="he-IL">בית
דין דתי</SPAN></FONT>, <FONT FACE="Nachlieli CLM"><SPAN LANG="he-IL">ראש
הוצאה לפועל לפי חוק ההוצאה לפועל</SPAN></FONT>,
<FONT FACE="Nachlieli CLM"><SPAN LANG="he-IL">תשכ</SPAN></FONT>&quot;<FONT FACE="Nachlieli CLM"><SPAN LANG="he-IL">ז</SPAN></FONT>-1967
(<FONT FACE="Nachlieli CLM"><SPAN LANG="he-IL">להלן </SPAN></FONT>-
<FONT FACE="Nachlieli CLM"><SPAN LANG="he-IL">חוק ההוצאה
לפועל</SPAN></FONT>), <FONT FACE="Nachlieli CLM"><SPAN LANG="he-IL">ולמעט
בית דין צבאי כמשמעותו בחוק השיפוט הצבאי</SPAN></FONT>,
<FONT FACE="Nachlieli CLM"><SPAN LANG="he-IL">תשט</SPAN></FONT>&quot;<FONT FACE="Nachlieli CLM"><SPAN LANG="he-IL">ו–
</SPAN></FONT>1955;
</P>

Notice the font and span tags end before each weak character and start again afterwords:
<SPAN LANG="he-IL">בית
משפט</SPAN></FONT>&quot; - <FONT FACE="Nachlieli CLM"><SPAN LANG="he-IL">לרבות
בית דין לעבודה</SPAN></FONT>,
Comment 1 Lior Kaplan 2013-04-25 16:06:03 UTC
Created attachment 78482 [details]
testdoc
Comment 2 Lior Kaplan 2013-04-25 16:21:25 UTC
This is a regression for 3.3.4, and also affects export to word formats. The report is done on HTML because it's very easy to demonstrate on it.

Setting importance major, as the doc/docx export problems prevents people using LibreOffice from working with Microsoft Office users (each save of the document alters the file drastically).
Comment 3 QA Administrators 2015-04-19 03:20:26 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 4 Buovjaga 2015-06-15 12:02:09 UTC
It's ok now:

<p class="P1"><span> "בית משפט" - לרבות בית דין לעבודה, בית דין דתי, ראש הוצאה לפועל לפי חוק ההוצאה לפועל, תשכ"ז-1967 (להלן - חוק ההוצאה לפועל), ולמעט בית דין צבאי כמשמעותו בחוק השיפוט הצבאי, תשט"ו– 1955; </span></p><p class="P1"><span> "גובה" - מוציא לפועל לפי חוק ההוצאה לפועל, בעל תפקיד לפי סעיף 5 לחוק האמור, פקיד של בית משפט או של הנהלת בתי המשפט וכן עובד ציבור שמינה מנהל המרכז לגביית קנסות, אגרות והוצאות, לצורך גביית חוב לפי חוק זה;</span></p>
Comment 5 Lior Kaplan 2015-08-27 12:24:17 UTC
Please give the version info you've used for your test.
Comment 6 Lior Kaplan 2015-08-27 15:17:37 UTC
Verified fix in 5.0.1 (Debian GNU/Linux, 64bit).

Notice the fix works fine in File -> Export, but doesn't work in File -> Save As.
Comment 7 Maxim Monastirsky 2015-08-27 15:38:20 UTC
FIXED status is when we know which commit fixed it.