Bug 63949 - Form controls disappear if top of page displayed
Summary: Form controls disappear if top of page displayed
Status: RESOLVED DUPLICATE of bug 43765
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA bibisected40
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-04-26 08:27 UTC by Laurent Godard
Modified: 2015-12-22 01:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
writer model with formular (61.30 KB, application/vnd.oasis.opendocument.text-template)
2013-04-26 08:27 UTC, Laurent Godard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Godard 2013-04-26 08:27:31 UTC
Created attachment 78505 [details]
writer model with formular

in the given file, some checkboxes in a formular

on opening a file, the checkoxes disappear if the top of the page is displayed

if you scroll down to not see the top of the page anymore, no more problem, the checkboxes controls are displayed correctly

different anchors (pages, paragraphs, characters) have been tested. same problem 
              
Operating System: Debian
Version: 4.0.2.2 release
Last worked in: 3.5.4 release
Comment 1 Joel Madero 2013-04-30 23:08:30 UTC
At least reproducible back to 4.0.0.3 release - updating version to reflect this.

 I have been able to confirm the issue on:
Version 3.6.6.2 
Platform: Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm this problem on an earlier release I am changing the version number as version is the earliest version that we can confirm the bug, we use comments to say that the bug exists in newer versions as well.

Marking as:

New (confirmed)
Minor - can look bad but really if you scroll the check boxes appear so it doesn't prevent high quality work per say.
High - looks quite bad + regression 

Keywords - regression

Whiteboard Status - bibisected40

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Joel Madero 2013-04-30 23:09:08 UTC
c45962a44092eb77881dc3be4e93cd90481993f4 is the first bad commit
commit c45962a44092eb77881dc3be4e93cd90481993f4
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Sun Dec 9 22:38:00 2012 +0000

    source-hash-786f730ea2608abaafdc656e2181d11e076b6648
    
    commit 786f730ea2608abaafdc656e2181d11e076b6648
    Author:     Gökçen Eraslan <gokcen.eraslan@gmail.com>
    AuthorDate: Sat Jul 7 19:08:48 2012 +0300
    Commit:     Gökçen Eraslan <gokcen.eraslan@gmail.com>
    CommitDate: Sat Jul 7 19:08:48 2012 +0300
    
        Add new chooseCertificate method to XDocumentDigitalSignatures UNO interface.
    
        This method shows the certificate choosing dialog previously used in ODF
        signing and returns the selected certificate. For PDF signing support,
        we need to reuse existing CertifacateChooser class of xmlsecurity module.
        So the UNO api of ::com::sun::star::security::XDocumentDigitalSignatures is
        extended.
    
        Change-Id: I09f7d0ee180b16b588798820206780df359d133e

:100644 100644 2e11de60e03551ff9cb9202630fabddffd9b4d03 5af276938ba298fec7eaa06d3f236ad82b750ff0 M	autogen.log
:100644 100644 df70cf1b2fb6e0b47fbcb057bac4ea7d21f35271 6661f695d92c988576c9d70fe300b0df76eb6ffa M	ccache.log
:100644 100644 f04e05c43f321169f9f15d5936d0e70837bc570e a6df55610d4b7784363613c35d2bc851614d5093 M	commitmsg
:100644 100644 ba3cdac99c84d838184d2b5509ae8d9cc61412ff 1fa2b23580ada6041c5b76f89a49f71f1d376c76 M	dev-install.log
:100644 100644 6ecbbd7b55ba204775bb230b601ddac2015876ba ef6ab6944c4175a1274a64f34770331fd54e95f5 M	make.log
:040000 040000 4cae16a4747816b3c7eea21bfb40c78e7dbebcca a2c07218979ed46d3cf8b53722a9716ce3e24c00 M	opt


# bad: [5b4b36d87517a6ea96ff8c84c46b12f462fc9a1a] source-hash-8450a99c744e9005f19173e4df35d65640bcf5c4
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9] source-hash-099198a4224778fe6e43f5dc13b5b9b1b4dc828c
git bisect good 16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9
# bad: [f28b8f9a6c47fa59bf98fffe937a2f2db7a2445a] source-hash-a581d31b227623e09d2970a91214fda398f98eda
git bisect bad f28b8f9a6c47fa59bf98fffe937a2f2db7a2445a
# bad: [5bf3b624cdeb593e55402f44c730209f12813961] source-hash-4b4ca8030285bd66526ff5bb2b6ea5a75a6c6bc7
git bisect bad 5bf3b624cdeb593e55402f44c730209f12813961
# good: [fbd64ab02c3b611eb2161132a98d2a24ccf109ad] source-hash-77987eacff20dec40caf29aae61d262239d441e9
git bisect good fbd64ab02c3b611eb2161132a98d2a24ccf109ad
# good: [8cd885615da6665d4d4eef81c3c1868f9e435a99] source-hash-bed3049c4c04a202ff288189d225ca6e5941d69b
git bisect good 8cd885615da6665d4d4eef81c3c1868f9e435a99
# bad: [7507f036925b44e11c82e0ba06c7ff4b1e45b2a4] source-hash-b7822657fa67e7265d07f5852057e975e9efae0d
git bisect bad 7507f036925b44e11c82e0ba06c7ff4b1e45b2a4
# good: [44785eb0abe0ce5298c148165ab829eb4bf645f3] source-hash-5218c0d6a8171400bee0d972ff05757849df4d19
git bisect good 44785eb0abe0ce5298c148165ab829eb4bf645f3
# bad: [c45962a44092eb77881dc3be4e93cd90481993f4] source-hash-786f730ea2608abaafdc656e2181d11e076b6648
git bisect bad c45962a44092eb77881dc3be4e93cd90481993f4
Comment 3 Michael Stahl (CIB) 2013-06-21 19:52:37 UTC
the bisect in comment #2 can't be quite right,
actually it's possible to make the form controls disappear
even in 3.5.x versions and the oldest bibisect build.
(clicking in the header usually lets them disappear).

so far i've tracked it down to

 (*pLayIter)->GetCurrShell()->LayoutIdle();

in SwDoc::DoIdleJobs which seems to make the difference
between hiding and non-hiding...
Comment 4 Michael Stahl (CIB) 2013-06-24 18:27:49 UTC

*** This bug has been marked as a duplicate of bug 43765 ***
Comment 5 Robinson Tryon (qubit) 2015-12-22 01:31:43 UTC
Removing comma from Whiteboard (please use a space to delimit values in this field)
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Whiteboard#Getting_Started
[NinjaEdit]