Download it now!
Bug 64006 - FILEOPEN: Crash loading SVG
Summary: FILEOPEN: Crash loading SVG
Status: RESOLVED DUPLICATE of bug 32248
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-28 00:25 UTC by Simon Phipps
Modified: 2014-07-24 19:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Standard SVG image of MariaDB logo from mariadb.org (26.83 KB, image/svg+xml)
2013-04-28 00:25 UTC, Simon Phipps
Details
crashlog (77.72 KB, text/plain)
2013-04-28 18:37 UTC, Jorendc
Details
Screenshot-of-SVG-opened-with-Draw4.1Beta1.png (105.05 KB, image/png)
2013-11-28 14:01 UTC, Gerry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Phipps 2013-04-28 00:25:33 UTC
Created attachment 78565 [details]
Standard SVG image of MariaDB logo from mariadb.org

Problem description: Draw crashed on loading the attached SVG file.

Steps to reproduce:
Load the attached SVG

Current behavior:
Crashes

Expected behavior:
Loads

              
Operating System: Mac OS X
Version: 4.0.1.2 release
Comment 1 Simon Phipps 2013-04-28 00:32:10 UTC
Also checked with 4.0.2.2, still crashes.
Comment 2 Jorendc 2013-04-28 18:36:38 UTC
Thanks for reporting.

I can reproduce this behavior using Mac OSX 10.8.3 with LibreOffice 4.0.3.1.

Opening this SVG file result in a crash. I'll attach the crashlog. Most probably not a Mac OSX-only bug.

Kind regards,
Joren
Comment 3 Jorendc 2013-04-28 18:37:41 UTC
Created attachment 78585 [details]
crashlog
Comment 4 Gerry 2013-04-30 14:46:01 UTC
Import (File->Open) works on LibreOffice 3.6.2.2 and 4.0.0.3. There are formatting errors, though: The colour is different and the text is absolutely missing. But no crash

Inserting (Insert->Picture->From File) works very fine under LibreOffice 3.6.2.2. Also inserting in 4.0.0.3 works fine, but there are layout issues. This is a regression. But no crashes.

System: Ubuntu 12.10.
Comment 5 Emir Sarı 2013-08-21 10:18:36 UTC
Could not reproduce this with Version: 4.2.0.0.alpha0+
Build ID: 6c4bedffb98a33b202692b225fc250b858ff9f65
TinderBox: MacOSX-X86_64@43, Branch:master, Time: 2013-08-21_02:59:18

Opens in Draw just fine.
Comment 6 Gerry 2013-11-28 14:01:01 UTC
Created attachment 89955 [details]
Screenshot-of-SVG-opened-with-Draw4.1Beta1.png

Tested with LibreOffice 4.2Beta1: 

* No crash on Ubuntu 13.04.
* Import as image in Writer: Perfect!
* Opening in Draw: Problematic. Gradients are wrong. Text is gone. See attachment.
Comment 7 Regina Henschel 2013-12-03 19:57:07 UTC
There exists several issues with File > Open a *.svg image. Missing text is tracked in bug 32248. Wrong import of drawings other than texts are already reported in bug 40088 and bug 43257. Closing as duplicate?
Comment 8 Jorendc 2014-07-24 19:54:58 UTC
(In reply to comment #7)
> There exists several issues with File > Open a *.svg image. Missing text is
> tracked in bug 32248. Wrong import of drawings other than texts are already
> reported in bug 40088 and bug 43257. Closing as duplicate?

Thanks Regina for pointing to existing bugs :-). I'll mark this one as dupe of 32248, but I can mark it as dupe of others too because this issue is covered by multiple bugs.

I also can add 47262 because of the gradient issue.

Kind regards,
Joren

*** This bug has been marked as a duplicate of bug 32248 ***