Bug Hunting Session
Bug 64079 - FILESAVE [DOCX]: Loss formulas of the 2003-format (Equation Editor 3.0) when editing DOCX-file
Summary: FILESAVE [DOCX]: Loss formulas of the 2003-format (Equation Editor 3.0) when ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-30 09:42 UTC by ape
Modified: 2016-04-05 17:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Original formulas in DOCX.pdf (250.57 KB, application/x-force-download)
2014-11-03 15:10 UTC, Timur
Details
Formulas exported to DOCX from LO 4.3.3 (3 OK).pdf (63.87 KB, application/x-force-download)
2014-11-03 15:11 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ape 2013-04-30 09:42:09 UTC
Attention!
Windows's users must use LibreOffice-4.0.x built after the 28th of April.

Re-export or edit DOCX file containing formulas of the 2003-format (Equation Editor 3.0), resulting in the loss of the formulas in LibreWriter-4. WinWord-2007 reveals such (re-exported) formulas as images.

To repeat the error, you must:
 - open the file (attachment 72390 [details]),
 - edit any word,
 - to save the file,
 - reload this file;
 or:
 - open the file (attachment 72390 [details]),
 - save the formulas.docx file in ODT format,
 - reload the new.odt file,
 - save the new.odt file in DOCX format,
 - reload the new.docx file.

 I looked into the new.docx container and saw:
 1. The format of formula’s images changed at WMF to EMF in the "new.docx\word\media\..".
 2. There are no binaries formulas:
 - binary objects "new.odt\Obj100;Obj101;Obj102" is not saved as OLE-objects "new.docx\word\embeddings\oleObject1.bin;oleObject2.bin;oleObject3.bin";
 - folder "new.docx\word\embeddings\..", which should contain binary objects-formulas is not in the container.
Comment 1 tommy27 2014-04-30 20:45:42 UTC
reproducible under Win7x64 using LibO 4.2.3.3 editing and saving attachment 72390 [details]

all formulas are lost in that .docx except the last one.

I suspect this has to do with OLE object and .docx format.

maybe a duplicate of Bug 51550 ?
Comment 2 Timur 2014-11-03 15:10:18 UTC
Created attachment 108843 [details]
Original formulas in DOCX.pdf

Tested with LO 4.3.3. First 3 formulas are there and they can be open.
BUT, 4th formula seems like it there, at least partially, but it cannot be edited.
Comment 3 Timur 2014-11-03 15:11:33 UTC
Created attachment 108844 [details]
Formulas exported to DOCX from LO 4.3.3 (3 OK).pdf
Comment 4 Timur 2016-04-05 15:36:26 UTC
LO 4.3.3 saved 3 formulas as OLE. 
In current versions LO converts all Equation OLE to Math, like explained in https://help.libreoffice.org/Common/Microsoft_Office. 

If saved to DOCX, it's open properly in MSO. 
Microsoft Word 2010 includes built-in support for writing equations to XML. Equation Editor is not used, but instead equations are edited directly from within Word. 

Tested with 5.0.5. I guess this one is for WFM.