Bug 64086 - Fileopen: named cell ranges from MSO are not imported in charts (because not supported in LO)
Summary: Fileopen: named cell ranges from MSO are not imported in charts (because not ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: All All
: medium normal
Assignee: Balázs Varga
URL:
Whiteboard: target:7.3.0
Keywords: filter:xlsx
Depends on:
Blocks: XLSX Cell-Name
  Show dependency treegraph
 
Reported: 2013-04-30 12:51 UTC by Marco A.
Modified: 2021-08-10 07:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Simple chart with named range (build with Excel 2003) (14.00 KB, application/vnd.ms-excel)
2013-04-30 12:51 UTC, Marco A.
Details
Test chart with named range from MSO.xlsx (16.81 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-07-24 16:36 UTC, Timur
Details
Chart with name range (15.03 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2021-07-21 18:01 UTC, Balázs Varga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco A. 2013-04-30 12:51:27 UTC
Created attachment 78647 [details]
Simple chart with named range (build with Excel 2003)

Named range doesn't work with chart. I use named range like values of a series (for example SpreadSheet1!MyDataRange), but work with MS-Excell.
Comment 1 Chris Sherlock 2013-04-30 16:37:53 UTC
Confirmed in  4.0.1.2.
Comment 2 Chris Sherlock 2013-04-30 17:44:18 UTC Comment hidden (obsolete)
Comment 3 Marco A. 2013-05-20 07:12:55 UTC
The same thing with Pivot table
Comment 4 mpapet 2015-02-15 17:45:24 UTC
I am having this issue pulled from Debian Jessie repos.

I define a range in calc, save document.  
Data->Pivot Table->Create

The "named range" option cannot be selected and my named range is not shown.

LibreOffice 4.3.3.2 430m0(Build:2)
Comment 5 QA Administrators 2017-01-03 19:36:19 UTC Comment hidden (obsolete)
Comment 6 russell 2017-03-11 08:19:06 UTC
This bug is still present in Libreoffice:

- 5.3.0.3 (linux mint 17.3)
- 5.2.3.3 (opensuse leap 42.2)

Libreoffice Calc does not support named ranges in Charts.

Usage example: Amortization table

Defined named range:
Principal = OFFSET($Table.$B$11,0,0,COUNT($Table.$B$11:$B$40,">0"),1)

Use defined name in Chart Data Ranges... -> Data Series -> Y-Values:
=amortization_test.ods!Principal

A dynamic amortization table, which is used as input to a chart, shows principal paid, interest paid, and balance amounts. The size (number of nonzero rows) of the table varies depending on input (amount, rate, term). 

As mentioned in the title, excel does support this.
Comment 7 Wolfgang Jäger 2017-08-18 11:38:55 UTC
There was a question in ask.libreoffice.org today I would judge to be related to this bug: 
https://ask.libreoffice.org/en/question/124256/dynamic-range-for-chart/ (I am 'Lupp' there.)

I would suggest to expand this topic to: 
"Named or calculated (by INDIRECT, OFFSET, INDEX) cell ranges cannot be selected for charts.", and to qualify the bug's 'Importance' as  'enhancement'. 

The functionality under discuission is still not available in LibO V 5.4.0.3. Calc. If someone knows a related statement in a specification, a help text, or a user guide, please post it (or a link) here.
Comment 8 Timur 2018-07-24 16:36:31 UTC
Created attachment 143731 [details]
Test chart with named range from MSO.xlsx

Let's make a distinction. Let Bug 66250 be about LO support for named ranges in LO, that's not available. And let bug 64086 be about import of MSO documents. 

I attach a test chart with named range created in MSO. "SerB" is not shown because it's named range in XLSX. If all data series are named ranges, chart looks empty.
Comment 9 Timur 2018-07-24 16:42:24 UTC
What worsens this issue from MSO side is: the cell reference in the formula will change to their defined names automatically, if we have defined names for the cell reference before (while the cell reference will not change to their defined names, if we create formulas for the cell reference before defining names).
Comment 10 Balázs Varga 2021-07-21 18:01:31 UTC
Created attachment 173759 [details]
Chart with name range
Comment 11 Commit Notification 2021-07-26 19:42:35 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3c766512984feff739377d0f0af46558ee7139fd

Related: tdf#64086 Add FormulaGrammar::isRefConventionOOXML()

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Wolfgang Jäger 2021-07-26 20:37:53 UTC
Will the patch also kill tdf#66250 ?
Comment 13 Eike Rathke 2021-07-28 18:52:24 UTC
That commit is just a prerequisite for
https://gerrit.libreoffice.org/c/core/+/118862
and does not solve anything (hence "Related" in the commit summary, not "Resolves" (which is only a convention I use to name things, nothing LibreOffice official)).
Comment 14 Commit Notification 2021-08-09 17:33:17 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/233286df08aeedb4e228fd523365b94543b16fca

tdf#64086 tdf#143623 tdf#66250 XLSX: fix named ranges in charts

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 NISZ LibreOffice Team 2021-08-10 07:29:52 UTC
Verified in:

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: eeeef98796df322d89912070c8e431c5f6d1283f
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded