Bug 64123 - FILESAVE: Line Width & Parameter Value of Error Bars on XY chart not properly saved
Summary: FILESAVE: Line Width & Parameter Value of Error Bars on XY chart not properly...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chart
  Show dependency treegraph
 
Reported: 2013-05-01 16:36 UTC by thomas.kaschel
Modified: 2022-11-18 08:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
XY graph shortly after the creation of the chart (69.90 KB, image/png)
2013-05-20 15:34 UTC, thomas.kaschel
Details
Same XY chart after closing and reopening the file (66.64 KB, image/png)
2013-05-20 15:35 UTC, thomas.kaschel
Details
Spreadsheet file (78.50 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-05-20 15:35 UTC, thomas.kaschel
Details
Test Kit (13.34 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-05-21 13:06 UTC, ign_christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description thomas.kaschel 2013-05-01 16:36:00 UTC
Adding an x error bar to a xy chart works, but it's no more there when saving the file and reopen. Y error bar works perfect.
Comment 1 ign_christian 2013-05-20 13:28:46 UTC
Could you please attach sample doc to test & how to reproduce?
Comment 2 thomas.kaschel 2013-05-20 15:34:05 UTC
Created attachment 79574 [details]
XY graph shortly after the creation of the chart

The chart looks as expected after it is created.
Comment 3 thomas.kaschel 2013-05-20 15:35:13 UTC
Created attachment 79575 [details]
Same XY chart after closing and reopening the file

After saving, closing and reopening the file the x error bars are no more shown.
Comment 4 thomas.kaschel 2013-05-20 15:35:51 UTC
Created attachment 79576 [details]
Spreadsheet file

Spreadsheet file with data and chart.
Comment 5 ign_christian 2013-05-21 02:33:25 UTC
Hi Thomas

Could you also explain step by step procedure to create that chart?
I don't familiar with this one :)
Is it happen with other charts?

Please inform your LO version & Linux distro.
Comment 6 thomas.kaschel 2013-05-21 07:20:32 UTC
(In reply to comment #5)
> Hi Thomas
> 
> Could you also explain step by step procedure to create that chart?
> I don't familiar with this one :)
> Is it happen with other charts?
> 
> Please inform your LO version & Linux distro.

LibreOffice v4.0.2.2 running on Xubuntu 13.04

The graph is a XY chart (points only). There are kind of gaps between the data points on the X axis (time) as well as on the Y axis (percentage). The X and Y error bars are used for closing these gaps by horizontal and vertical lines. Column C represents the data points, column D the value for the X error bars and column E for the Y error bars.

After creating the XY (points only) chart a right-click offers the option to add X and Y error bars. Unfortunately the X error bars are not saved.
Comment 7 ign_christian 2013-05-21 08:23:25 UTC
We can see the difference from your attachments. But it's difficult for me to create new chart, same as yours, from your limited explanation to see that issue from scratch.

I tried looking properties of your ready-made chart. Found that X Error Bars is 0 (zero) width.

Could you confirm that? I believe it shouldn't be zero. 
If yes, please try playing with some width & check if it reset to zero after saving & reopening file.
Comment 8 thomas.kaschel 2013-05-21 09:36:14 UTC
(In reply to comment #7)
> We can see the difference from your attachments. But it's difficult for me
> to create new chart, same as yours, from your limited explanation to see
> that issue from scratch.
> 
> I tried looking properties of your ready-made chart. Found that X Error Bars
> is 0 (zero) width.
> 
> Could you confirm that? I believe it shouldn't be zero. 
> If yes, please try playing with some width & check if it reset to zero after
> saving & reopening file.

I have set the width of the X error bars to 0,05cm but LO obviously doesn't save this information. So the X error bars aren't shown after reopening the file.
Comment 9 ign_christian 2013-05-21 13:06:19 UTC
Created attachment 79618 [details]
Test Kit

Based on Thomas attachment, I tried to make a test file (attached)

Steps to reproduce:
1. Insert > Chart > Chart Type > XY(Scatter) > Next
2. Data range > $Sheet1.$A$2:$B$22 > Unchek both 'First row as label' & 'First column as label' > Finish
3. Select & click any Data Point > right click > Insert X Error Bars
4. Selection: 
Tab 'X Error Bars'
- Error Category: Cell Range
- Error Indicator: Positive
- Parameters -> Positive (+): $Sheet1.$C$2:$C$22
Tab 'Line' -> Width: 0,05cm
5. Repeat step 3-4 to Insert Y Error Bars (except for: Parameters -> Positive (+): $Sheet1.$D$2:$D$22)
6. Save, close, & reopen this file
7. We can see changes on X Error Bars:
# Width -> 0,00cm
# Parameters -> Positive (+): $Sheet1.$D$2:$D$22

Doing only steps 1-4,6 (only Insert X Error Bars) generates different behavior:
Positive Parameters no change, but Width: 0,00cm

Doing same procedure with XLS & XLSX, removing both X & Y Error Bars.

Tested on LO 4.0.3.3 (Win7 32bit)
Comment 10 QA Administrators 2015-04-19 03:21:37 UTC Comment hidden (obsolete)
Comment 11 QA Administrators 2016-09-20 09:24:53 UTC Comment hidden (obsolete)
Comment 12 QA Administrators 2021-02-08 03:47:58 UTC Comment hidden (obsolete)
Comment 13 Stéphane Guillou (stragu) 2022-11-18 08:53:48 UTC
I could not reproduce following the steps in comment 9 -> Worksforme

Version: 7.5.0.0.alpha0+ (X86_64) / LibreOffice Community
Build ID: 45d1fca81991f0d6837c98d6be6fe0d21d566fa5
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

Seems it was already fixed in:

Version: 6.3.6.2
Build ID: 2196df99b074d8a661f4036fca8fa0cbfa33a497
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3; 
Locale: en-AU (en_AU.UTF-8); UI-Language: en-US
Calc: threaded