Download it now!
Bug 64147 - : open multi selected documents (in Finder)
Summary: : open multi selected documents (in Finder)
Status: RESOLVED DUPLICATE of bug 54264
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-05-02 12:55 UTC by easyw
Modified: 2013-05-02 13:32 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
error dialog opening docs from finder (not from LO open file dialog) (82.16 KB, image/png)
2013-05-02 12:55 UTC, easyw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description easyw 2013-05-02 12:55:15 UTC
Created attachment 78777 [details]
error dialog opening docs from finder (not from LO open file dialog)

Problem description: 
open multi selected documents (using Finder)
Steps to reproduce:
LO Version 4.0.2.2
under Mac OSX Lion on Intel core i7 64bits

when I click to open a single document selected in Finder everything is fine,
but if I select 2 or more LO documents, and I click to open them, LO starts but I receive the following dialog error: /Users/Mac/Documents/doc1.odt /Users/Mac/Documents/doc2.odt does not exist.
in both way it works correctly (I can open multi documents from the LO menu selecting them with or without ‘Use LibreOffice Dialogs’ selected)…

the problem appears only when I select 2 or more LO documents, and I click to open them, on the Finder folder (not from LO open document menu) … 
As following: 
- launch Finder
- go to the doc folder
- select 2 or more LO docs
- double click with the mouse to launch LO

LO starts but I receive the following dialog error: /Users/Mac/Documents/doc1.odt /Users/Mac/Documents/doc2.odt does not exist.
(in this test I selected doc1.odt and doc2.odt in Finder and I double clicked to open both of documents…)

it seems that the parameters sent to LO from Finder are not correctly managed if there is more then one doc…

Current behaviour:
I receive the following dialog error: /Users/Mac/Documents/doc1.odt /Users/Mac/Documents/doc2.odt does not exist.
Expected behaviour:
open the selected documents

in OOo 3.3.0 OSX everything were fine, but in recent versions (as in recent LO) I noticed this beahviour
              
Operating System: Mac OS X
Version: 4.0.2.2 release
Last worked in: 3.3.0 release
Comment 1 Jorendc 2013-05-02 13:32:57 UTC

*** This bug has been marked as a duplicate of bug 54264 ***