Download it now!
Bug 64151 - CONFIGURATION: not enough space for "length" in Options → LibreOffice Writer → Comparison
Summary: CONFIGURATION: not enough space for "length" in Options → LibreOffice Writer ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.3.1 rc
Hardware: All All
: medium minor
Assignee: Caolán McNamara
URL:
Whiteboard: BSA target:4.0.5 target:4.1.0.0.beta2
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-02 13:58 UTC by Reuben Thomas
Modified: 2013-06-05 09:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of 4.1 beta 1 on mac osx 10.8.3 (93.31 KB, image/png)
2013-06-01 07:37 UTC, Thomas van der Meulen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Reuben Thomas 2013-05-02 13:58:12 UTC
Problem description: 

The label "Ignore pieces of lengt" should read "Ignore pieces of length".

I'm using the en_GB locale, but I suppose this string may also come from the en_US locale.
Operating System: Ubuntu
Version: 4.0.3.2 rc
Comment 1 Thomas van der Meulen 2013-05-03 06:51:55 UTC
thank you for your bug report, I can reproduce this bug running LibreOffice 4.0.3.1 and 4.0.3.2 on Mac osx 10.8.3 

I set the priority to minor and the version to 4.0.3.1 because i could reproduce it dare to
Comment 2 Adolfo Jayme 2013-05-03 18:35:04 UTC
The typo does not show up when I search for it in http://opengrok.libreoffice.org. So maybe the label is just cut off in the UI (?).
Comment 3 Thomas van der Meulen 2013-05-03 19:44:58 UTC
found it!: http://opengrok.libreoffice.org/xref/core/sw/source/ui/config/optdlg.src 

it is one row number 700 just need a devoloper to fix this.
Comment 4 Julien Nabet 2013-05-31 20:41:57 UTC
On pc Debian x86-64 with LO 4.0.3 Debian packages + localization en-GB, I don't reproduce this.
It seems someone fixed this.
Reuben, could you give a try to 4.0.3 final release? (see LO ppa, https://launchpad.net/~libreoffice/+archive/ppa)
Comment 5 Thomas van der Meulen 2013-06-01 07:36:04 UTC
I can still reproduce this bug running LibreOffice Version: 4.1.0.0.beta1
Build ID: 3a2c2d2417101e45fe07cfd8358acf2204a98f3 on Mac osx 10.8.3.
Comment 6 Thomas van der Meulen 2013-06-01 07:37:31 UTC
Created attachment 80108 [details]
screenshot of 4.1 beta 1 on mac osx 10.8.3
Comment 7 Julien Nabet 2013-06-04 19:35:59 UTC
Thomas: it's not a problem of typo but of lack of space for the final "h"

Caolán: I noticed that the widget conversion was made with this commit:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=c99830c221cd2362d58caac15dd2fb33a2b1ad38
so if it should be present for 4.2.0 but what is possible to do for current versions?
Comment 8 Julien Nabet 2013-06-04 19:59:11 UTC
Thomas: meanwhile, is the option scaling (Tools/Options/LibreOffice/View) at 100% or more?
If already 100%, perhaps try a little less? (eg:95%)
Comment 9 Thomas van der Meulen 2013-06-04 20:04:11 UTC
Julien: I knew that it wasn't a typo but it lack of space,
I tested with 4.1 beta 1 on mac osx 10.8.3 and only on 100% it is "cut of" on <99% it is fine.
Comment 10 Julien Nabet 2013-06-04 20:07:46 UTC
Thomas: no problem, I've updated the title of the bugtracker so it's more obvious now :-)
Comment 11 Caolán McNamara 2013-06-05 08:38:25 UTC
This sort of stuff is one of the reasons for widget layout.

For the old school stuff the sw/source/ui/config/optdlg.src had...

Pos = MAP_APPFONT ( 100 , 80 ) ;

for the spinfield and

Pos = MAP_APPFONT ( 12 , 82 ) ;
Size = MAP_APPFONT ( 70 , 10 ) ;

for the checkbox, so seeing as the checkbox text is slightly truncated if we change the width of its Size from 70 to 80 then the last h will surely fit. With 80 + 12 = 92 for the right edge which is still before the 100 x pos of the spinfield so it won't overlap and we don't have to move everything else around. (presumably a pile of other translations still don't fit and a perfect pre-widget-layout solution requires checking each and every one to get the best size to fit all)

https://gerrit.libreoffice.org/4162 for 4.0
Comment 12 Commit Notification 2013-06-05 08:50:31 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9743dc5aca9f286b869614c944168737a2c2be28&h=libreoffice-4-0

Resolves: fdo#64151 increase checkbox size to fit last 'h' into it


It will be available in LibreOffice 4.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Caolán McNamara 2013-06-05 09:10:58 UTC
and we can just backport the widget layout master to 4.1 as we're still inside the translation window
Comment 14 Commit Notification 2013-06-05 09:11:49 UTC
abdulmajeed ahmed committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cedb8f7995f0085bf1b851553f88b87118dfccda&h=libreoffice-4-1

Resolves: fdo#64151 Convert Comparison tab page to .ui


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.