Download it now!
Bug 64188 - Word completion often makes wrong suggestion when typing very fast
Summary: Word completion often makes wrong suggestion when typing very fast
Status: RESOLVED DUPLICATE of bug 62643
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-03 14:59 UTC by Wirawan Purwanto
Modified: 2015-03-28 18:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wirawan Purwanto 2013-05-03 14:59:16 UTC
I recently use LibreOffice 4.0.1.2 and 4.0.2.2 to transcribe in a meeting. I typed very fast and I notice that often the word suggestion often suggests wrong words, even words that don't exist. For example, if I begin to type "attention", then in the middle, say, after the second "n", it will look for words that begin with "n", instead of "atten". So it will suggest words such as "atteneither", etc. I found that this kind of error would happen sporadically, and ONLY when I type really fast. It appears to me that the bug has to do with a race condition among several threads. I can't provide screenshot right now; I will upload one if I can encounter the bug again soon.

Settings:
* Language: English (USA)
* I turned off spell checking
* In word completion dialog box, I chose:
   [v] enable word completion
      [ ] append space
      [ ] show as tip
   [v] collect words
      [ ] when closing a document ...
   Accept with: [Return]
   Min word length: [6]
   Max entries: [5000]
* OS: Linux Debian 6.0.7, x86_64, kernel 3.2.0-0.bpo.4-amd64, GNOME 2 desktop
Comment 1 HansPL 2013-06-12 14:26:44 UTC
Confirmed for LO 4.0.3.3 in Linux Mint Debian Edition amd64, German l10n & language.  

I noticed the same behavior since updating from LO 3.x,  rendering Autocomplete worthless.

Obviously a regression.  This might also explain several reports about Writer crashes while simply typing?  I have also already experienced such crashes!
Comment 2 Wirawan Purwanto 2013-06-17 18:29:40 UTC
I believe this bug is the same as https://bugs.freedesktop.org/show_bug.cgi?id=62643 .
Comment 3 QA Administrators 2015-03-16 23:32:43 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

    Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
    https://www.libreoffice.org/download/

    If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
  
  If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

    Update the version field
    Reply via email (please reply directly on the bug tracker)
    Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-03-16
Comment 4 Jean-Baptiste Faure 2015-03-28 18:20:20 UTC
(In reply to Wirawan Purwanto from comment #2)
> I believe this bug is the same as
> https://bugs.freedesktop.org/show_bug.cgi?id=62643 .

Ok, so closing as duplicate of bug 62643.

thank you.

*** This bug has been marked as a duplicate of bug 62643 ***