Bug Hunting Session
Bug 64199 - SLIDESHOW: Sound and video files don't work in 4.x when added in 3.x
Summary: SLIDESHOW: Sound and video files don't work in 4.x when added in 3.x
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other All
: high critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-03 21:05 UTC by Derek
Modified: 2015-06-21 11:37 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
This is an example - started in 4xxx, edited to add some sound and video in 3xxx, plays correctly in 3xxx but locks up on loading into 4xxx. Removing the video slide (slide 1) allows it to load in 4xxx (721.76 KB, application/vnd.oasis.opendocument.presentation)
2013-05-03 21:05 UTC, Derek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Derek 2013-05-03 21:05:21 UTC
Created attachment 78826 [details]
This is an example - started in 4xxx, edited to add some sound and video in 3xxx, plays correctly in 3xxx but locks up on loading into 4xxx. Removing the video slide (slide 1) allows it to load in 4xxx

Problem description: I use four different machines, 2 running Linux Mint 14 and 2 running Mint 13 One of the Mint 13 machines uses LOo 3.6.5.2 the others have 4.0.2.2
This bug refers only to 4.0.2.2 but occurs on all three and all three ran 3.6.5.2 correctly.
When a video file is loaded, it either locks or hangs for a significant period - LOo 3xxx takes only moments to complete. This is universal.
When I seek to transition a slide sound, nothing appears to happen and no sound is played when the show is presented. If I take the file to 3.6.5.2 it plays as expected.

Steps to reproduce:
1a. Insert > Movie & Sound
2a. Select movie file

1b. Slide transition > sound > other sound
2b. select sound file


Current behaviour: a) Either locks up at this point and have to crash out - file not present on recovery OR hangs for minutes before file in shown on slide ( only loads on one Mint 13 machine, haven't tried playing it - sorry)
b) Nothing appears to have happened, sound transition area doesn't change, slide show does not play sound file.

Expected behaviour: Both cases the slide shows the file or filename shown in the transition bar and video/sound plays during slideshow.

If I take an apparently lifeless 4xxx presentation it plays correctly on 3xxx. If I take a working 3xxx presentation WHICH DOES NOT CONTAIN A VIDEO it will load in 4xxx but no sound is produced from the slide show. If the 3xxx presentation contains a video them Impress 4xxx locks/hangs (usually locks) and has to be crashed. (Slows down the whole machine's response times while locked.)

Reversion to 3xxx on the machine doesn't complete correctly and is something I'm still working on.
Operating System: Ubuntu
Version: 4.0.2.2 release
Comment 1 ign_christian 2013-05-14 15:19:05 UTC
I can confirm that media on slide 1 (attached file) not loaded -> tested using LO 4.0.3.3 (Win7 Home Premium 32bit)
Comment 2 Derek 2013-05-16 02:44:10 UTC
SOLVED

... or at least, fixed. I re-purged the old 3.x installation and completely removed the 4.0.3x installation. I re-installed from freshly downloaded debs and all works swimmingly except it loads by default to /opt/libreoffice and not the standard path. A small problem which is probably solved with a "proper" Mint package download.

On another machine, another package requires libreoffice-core to be a standard install and so it loaded some elements of 3.x because it couldn't find the files from the downloaded debs installation (as outlined above) and this, too, caused problems but that, too, is now fixed with some symlinks.
Comment 3 ign_christian 2013-05-17 16:31:11 UTC
set Platform to: All  -> known problem on Ubuntu & Win7
Comment 4 Zeki Bildirici 2013-10-09 21:28:07 UTC
(In reply to comment #3)
> set Platform to: All  -> known problem on Ubuntu & Win7

(In reply to comment #3)
> set Platform to: All  -> known problem on Ubuntu & Win7

Confirmed on LibreOffice 4.1.2.2 on Windows 

A very similar problem is also reported from our forum. Here is the link: https://dl.dropboxusercontent.com/u/46895032/going%20to%20the%20theatre%20teacher.odp file causes similar problems (for some both item a and b for some only b)and locks Impress.

My file seems to be problematic in Linux systems, i asked my friends and the problem is confirmed with:
1- OS: Manjaro 0.8.7 Ascella
Kernel: x86_64 Linux 3.11.2-1-MANJARO
LO: 4.1.1.2 Arch Linux build-2
2- Debian/Jessie altında LibreOffice 4.1.1.2 
3- Ubuntu 13.04 LibreOffice 4.1.1
4- Fedora 19 Gnome 64bit

Controversially, the file i've attached going to the theatre teacher.odp can be opened by Ubuntu 12.10 - LibreOffice 3.5.x and 3.6.x series without any problems.

Best Regards,
Zeki
Comment 5 Julien Nabet 2014-03-11 20:52:13 UTC
Derek: I gave a try with your file but it failed. Unzipping it, I noticed the media file wasn't included but just linked, I'm quoting content.xml:
draw:plugin xlink:href="../notices/notices-start.avi" xlink:type="simple" xlink:show="embed" xlink:actuate="onLoad" draw:mime-type="application/vnd.sun.star.media"
Anyway, you indicated it was ok for you in comment 2.

Zeki: on pc Debian x86-64 with 4.2 sources updated some days ago, I don't reproduce this. I noticed that the media file was included in the odp (that's why I could listen something).

So I put it as WFM. However, don't hesitate to reopen this if you can still reproduce this.
Comment 6 Joel Madero 2015-05-02 15:43:24 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 7 Buovjaga 2015-06-21 11:37:14 UTC
Julien forgot to change status to WFM.