Bug 64264 - FILEOPEN: Table in docx is not rendered correctly due "repeat heading" (bad handling of isolated tblHeader row settings)
Summary: FILEOPEN: Table in docx is not rendered correctly due "repeat heading" (bad h...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: László Németh
URL:
Whiteboard: BSA target:6.2.0 target:6.1.2
Keywords: filter:docx
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2013-05-06 06:28 UTC by rx8000
Modified: 2018-10-13 10:45 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file I've received (23.52 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-05-06 06:28 UTC, rx8000
Details
What this file looks like in LibO (35.53 KB, image/png)
2013-05-06 06:29 UTC, rx8000
Details
What it should look like (as in Word 2010) (39.94 KB, image/png)
2013-05-06 06:29 UTC, rx8000
Details
Sample saved in Word without "Repeat as header row" opens OK (17.90 KB, application/vnd.openxmlformats-officedocument.wordprocessingml)
2015-05-20 17:10 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rx8000 2013-05-06 06:28:29 UTC
Created attachment 78905 [details]
Sample file I've received

Problem description: a long table in docx is cut off, pages appear empty. no chance to see the rest of the table.

Steps to reproduce:
Just see the attached docx-file. I do not know how the original file was created.

Current behavior: page 1: empty, page 2: table ist cut off, page 3: empty

Expected behavior: table should spread over 2,5 pages

              
Operating System: All
Version: 4.0.2.2 release
Comment 1 rx8000 2013-05-06 06:29:08 UTC
Created attachment 78906 [details]
What this file looks like in LibO
Comment 2 rx8000 2013-05-06 06:29:35 UTC
Created attachment 78907 [details]
What it should look like (as in Word 2010)
Comment 3 rx8000 2013-05-06 10:41:20 UTC
You get the full table if you 

- rightclick on the table
- click "Table..."
- select "Text Flow"
- Uncheck "Repeat Heading"
Comment 4 Jorendc 2013-05-06 10:47:52 UTC
Thank for reporting!

I can reproduce this behavior using Linux Mint 14 x64 with LibreOffice 4.0.3.3. Also with Version: 4.1.0.0.alpha0+ Build ID: c458ea6d15465d9dada06f259946f854e9e5ccf

(In reply to comment #3)
> You get the full table if you 
> 
> - rightclick on the table
> - click "Table..."
> - select "Text Flow"
> - Uncheck "Repeat Heading"

I can reproduce that.
Important note: *on the table of the second page* :)


Kind regards,
Joren
Comment 5 rx8000 2013-05-06 11:16:39 UTC
(In reply to comment #4)
> Important note: *on the table of the second page* :)

You are right, sorry, I missed that
Comment 6 Xisco Faulí 2014-03-12 17:04:12 UTC
Confirmed in Windows 7 Enterprise with:
   - Libreoffice 4.1.4.2 Build  ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72
   - Libreoffice 4.2.1.1 Build  ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b
   - Libreoffice 4.3.0.0.alpha0 ID: 9aa241f0370ab22096a9b1d70040130743448a65
Comment 7 Matthew Francis 2015-04-10 12:46:32 UTC
Occurs back to LO / OOo 3.3.0
-> Version: Inherited from OOo
Comment 8 Timur 2015-05-20 17:10:50 UTC
Created attachment 115753 [details]
Sample saved in Word without "Repeat as header row" opens OK

Sample file (reduced) when saved in Word without table option "Repeat as header row" opens OK in LO.
Comment 9 QA Administrators 2016-09-20 09:41:55 UTC Comment hidden (obsolete)
Comment 10 Mike Kaganski 2018-05-31 10:19:24 UTC

*** This bug has been marked as a duplicate of bug 58944 ***
Comment 11 László Németh 2018-09-19 11:19:36 UTC
It seems, this is not the duplicate of Bug 58944. Here the problem is the bad handling of the OOXML standard related to the single tblHeader settings within the table without previous tblHeader settings.
Comment 12 László Németh 2018-09-19 12:18:28 UTC
Proposed solution: https://gerrit.libreoffice.org/#/c/60765/
Comment 13 Commit Notification 2018-09-20 05:55:10 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ace6bbf3da9ae27aca87865b6be887a3aed341fc

tdf#64264 DOCX import: fix row count of repeating table header

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2018-09-20 08:16:50 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=caa2b68b9f3d686aa6f99e3e341b0f76e9e4ce46&h=libreoffice-6-1

tdf#64264 DOCX import: fix row count of repeating table header

It will be available in 6.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 BogdanB 2018-10-13 10:45:51 UTC
Works ok on
Version: 6.2.0.0.alpha0+
Build ID: 144da6d5079bcd435e6637cb5cf95305f3ec1306
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-10-12_02:13:01
Locale: ro-RO (ro_RO.UTF-8); Calc: threaded