Bug 64298 - Support IMR_QUERYCHARPOSITION for better integration with IMEs
Summary: Support IMR_QUERYCHARPOSITION for better integration with IMEs
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: All Windows (All)
: medium normal
Assignee: Yohei Yukawa
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-06 22:53 UTC by Yohei Yukawa
Modified: 2013-11-21 13:22 UTC (History)
4 users (show)

See Also:


Attachments
Suggestion Windows is not aligned on Writer. OK on MSWord. (65.14 KB, image/png)
2013-05-06 22:53 UTC, Yohei Yukawa
Details
Suggestion Windows is not aligned on Writer. OK on MSWord. (65.14 KB, image/png)
2013-05-06 22:55 UTC, Yohei Yukawa
Details
Proposed patch to support IMR_QUERYCHARPOSITION for Writer and Calc (19.39 KB, patch)
2013-05-06 22:57 UTC, Yohei Yukawa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yohei Yukawa 2013-05-06 22:53:45 UTC
Created attachment 78949 [details]
Suggestion Windows is not aligned on Writer. OK on MSWord.

Currently LibreOffice does not support Win32 IMR_QUERYCHARPOSITION request.
http://listarchives.libreoffice.org/ja/discuss/msg01839.html

IMR_QUERYCHARPOSITION is one of optional but fundamental requests issued from IMEs to application. This message is used to retrieve the positional information about positional information of composition characters drawn by the application.
This information is critical for IMEs to align suggestion window with the composition text.

Starting with Windows 8, built-in MSIME starts using suggestion UI. So it would be nice if LibreOffice can support IMR_QUERYCHARPOSITION like Microsoft Word.
Comment 1 Yohei Yukawa 2013-05-06 22:55:17 UTC
Created attachment 78950 [details]
Suggestion Windows is not aligned on Writer. OK on MSWord.
Comment 2 Yohei Yukawa 2013-05-06 22:57:12 UTC
Created attachment 78951 [details]
Proposed patch to support IMR_QUERYCHARPOSITION for Writer and Calc
Comment 3 Yohei Yukawa 2013-05-06 23:10:01 UTC
If I should send this patch directly to gerrit.libreoffice.org, please let me know.

Thanks,
Comment 4 Michael Meeks 2013-05-10 10:33:21 UTC
Yes in general gerrit is best wrt. finding reviewers - on the other hand - this looks like a really sexy feature :-) I'd love to see it in 4.1 (feature freeze next week). Tor - a windows feature, any chance of a quick sanity check / review ?

Nice work Yohei !
Comment 5 Don't use this account, use tml@iki.fi 2013-05-10 11:28:06 UTC
"quick"? Windows? no;)
Comment 6 Don't use this account, use tml@iki.fi 2013-05-10 11:33:39 UTC
In other words, if I start a build of master now, it will be ready by Monday. (I don't keep my noisy, power-hungry Windows box running outside work hours, and even then only when I am actually working on some Windows thing.)
Comment 7 Michael Meeks 2013-05-10 11:58:07 UTC
Ok - I have a live windows build here, I'll cherry-pick, test-compile - if you glance at the code, lets get it in and see how it goes :-)
Comment 8 Yohei Yukawa 2013-05-10 19:53:50 UTC
Thank you for the information.

Here is the entry for Gerrit.
https://gerrit.libreoffice.org/#/c/3849/
Comment 9 Mat M 2013-05-11 09:28:38 UTC
Hello Yohei

BugZilla is very open, so moving to the Assigned state did not assign yourself to the bug. So I do it for you, assuming this was what you expected.

And thanks for the patch :)
Comment 10 Yohei Yukawa 2013-05-13 03:44:19 UTC
Wow, yes, that is what I intended. Thanks!
Comment 11 Don't use this account, use tml@iki.fi 2013-05-13 09:29:15 UTC
The gerrit patch was merged, so presumably this bug can be resolved.
Comment 12 Michael Meeks 2013-05-13 09:38:15 UTC
Will ship in 4.1 - going into feature freeze in a week:
https://wiki.documentfoundation.org/ReleasePlan/4.1

would be really great to have your nice screenshot in:

https://wiki.documentfoundation.org/ReleaseNotes/4.1

with your name next to it - could you add it there ? :-)

Thanks !
Comment 13 Yohei Yukawa 2013-05-13 09:52:44 UTC
Sure. I'll do it after today's nightly build becomes available.
Thank you for your assistance!
Comment 14 Kohei Yoshida 2013-05-13 20:21:40 UTC
I just built the latest on Windows with this enhancement. I can confirm that this is working beautifully. Great work! :-)
Comment 15 Yohei Yukawa 2013-05-16 11:22:14 UTC
Added a screenshot in https://wiki.documentfoundation.org/ReleaseNotes/4.1#Writer
Thanks!