Bug Hunting Session
Bug 64370 - Templates with Different File Name but Same Title are not Displayed in Template Manager
Summary: Templates with Different File Name but Same Title are not Displayed in Templa...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Template-Manager
  Show dependency treegraph
 
Reported: 2013-05-08 21:41 UTC by Harald Koester
Modified: 2018-12-04 22:13 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2013-05-08 21:41:03 UTC
In order to reproduce do:

[1] Create new text document template: 
  (a) Open new document and insert some letters 
  (b) Set document title to „Test“: File → Properties... → Description → Title
  (c) Save file as text document template (e.g. Test1.ott) into your template folder, do not close document

[2] Create another template with the same title:
  (a) Go on with the same document, modify document.
  (b) Save file as text document template but with a different file name (e.g. Test2.ott)

[3] Close document.

[4] Display text document templates: Click on „Templates...“ → Documents → My Templates. Only one template with the name „Test“ is displayed !!! Expected: Display of two templates with the name „Test“. It would be even better if the file name is also displayed: e.g. „Test (Test1.ott)“

I assume that the same problem also exists with the other types of templates (spreadsheets, etc.), but I did not checked it.
Comment 1 Joel Madero 2013-05-10 18:59:56 UTC
Hm this is by design so I want to get the right feedback.

Cedric & Rafael - thoughts here?
Comment 2 Cédric Bosdonnat 2013-05-14 13:57:31 UTC
(In reply to comment #1)
> Hm this is by design so I want to get the right feedback.
> 
> Cedric & Rafael - thoughts here?

I guess it's a design bug... and for sure this needs to be addressed.
Comment 3 Cor Nouws 2013-10-20 19:32:17 UTC
honestly, as far as I know this has been the case for a long time in OOo too.

(There is some meganism behind doning stuff with UI names and a different file holding numbers, pulling names together from different locations. Ah well..)
Comment 4 Cédric Bosdonnat 2014-01-20 09:00:24 UTC
Restricted my LibreOffice hacking area
Comment 5 Joel Madero 2015-05-02 15:42:20 UTC Comment hidden (obsolete)
Comment 6 Cor Nouws 2015-05-03 15:03:37 UTC
Still the same in 4.4.3.2
Comment 7 g_winkelmann 2016-02-21 08:57:51 UTC
I am confused about the status to show the "name" (hiding under options/preferences/property (I don't know the English term for "Eigenschaft") of the document) and no file name.
I realized this after reading this bug.
So I want the feature to get the information about the file name of the template.
The actual situation is that I copy any template with another file name to change it and save as another file name. And wonder why I cannot see the change in the Template Manager!
Comment 8 Joel Madero 2016-02-21 16:58:34 UTC
Please don't mess with the top stuff if you don't know what all of it means. Reverting changes.
Comment 9 QA Administrators 2017-11-26 17:11:59 UTC Comment hidden (obsolete)
Comment 10 Harald Koester 2017-11-30 20:03:05 UTC
Checked again with version 5.4.3. With the new template manager the bug does not appear any longer. Hence set to RESOLVED WONTFIX.
Comment 11 Harald Koester 2017-11-30 21:18:19 UTC
My last comment is not complete. If you save a template with "Menu: File > Templates > Save as template ..." there is no problem. But if you save templates with "Menu: File > Save as... > Type file name and choose file type: ODF Text Document Template (.ott) (*.ott)" the proplem still exists. Hence set status back to NEW.
Comment 12 QA Administrators 2018-12-03 03:59:23 UTC Comment hidden (obsolete)
Comment 13 Harald Koester 2018-12-04 22:13:19 UTC
Bug according comment 11 still exists with version 6.1.3 (64 bit, Win 10).