Download it now!
Bug 64461 - SVG image text with "flowed text frame" will be imported as a black box
Summary: SVG image text with "flowed text frame" will be imported as a black box
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL: http://wiki.inkscape.org/wiki/index.p...
Whiteboard:
Keywords: filter:svg
Depends on:
Blocks: SVG-Import SVG-Open
  Show dependency treegraph
 
Reported: 2013-05-11 11:37 UTC by ilikebigbugs
Modified: 2019-08-06 10:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
image showing the behavior (39.88 KB, image/png)
2013-05-11 11:37 UTC, ilikebigbugs
Details
example svg file (3.79 KB, image/svg+xml)
2013-05-11 11:37 UTC, ilikebigbugs
Details
SVG in Draw 6.1 beta 2+ (4.35 KB, image/png)
2018-06-17 15:22 UTC, Roman Kuznetsov
Details
SVG in Inkscape 0.92.3 (12.91 KB, image/png)
2018-06-17 15:24 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ilikebigbugs 2013-05-11 11:37:09 UTC
Created attachment 79146 [details]
image showing the behavior

text_frame.png
XP, LO Version 4.0.4.0+
Insert->Picture->From File
text only works if there is no "flowed text frame"
(in Inkscape only clicking on the canvas and then typing will work) 


some comments/testing on SVG import can be found here:
http://en.libreofficeforum.org/node/293
Comment 1 ilikebigbugs 2013-05-11 11:37:49 UTC
Created attachment 79147 [details]
example svg file
Comment 2 Jorendc 2013-05-22 17:52:26 UTC
Thanks (again ;-) ) for reporting.

I can reproduce this behavior using Linux Mint 15 x64 with LibreOffice 4.0.3.3 and LibreOffice Version: 4.2.0.0.alpha0+ Build ID: 66c315bcf2b78c4928d1e436d1a853f58f4cccd 

Kind regards,
Joren
Comment 3 A (Andy) 2015-04-05 21:24:50 UTC
Reproducible with LO 4.4.1.2 (Win 8.1):
Image text with "flowed text frame" will be imported as a black rectangle
Comment 4 Robinson Tryon (qubit) 2015-12-10 04:24:28 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2016-10-08 18:21:17 UTC
This is still reproducible in

Version: 5.3.0.0.alpha0+
Build ID: ae3ec79354f7b4967e736c6a4cd7c08fc52e2b7d
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 6 Xisco Faulí 2016-10-10 18:17:52 UTC
Actually the rendering is correct at import time but not when opening.
Comment 7 QA Administrators 2018-02-27 03:34:00 UTC Comment hidden (obsolete)
Comment 8 Roman Kuznetsov 2018-06-17 15:22:33 UTC
Created attachment 142823 [details]
SVG in Draw 6.1 beta 2+
Comment 9 Roman Kuznetsov 2018-06-17 15:24:33 UTC
Created attachment 142824 [details]
SVG in Inkscape 0.92.3
Comment 10 Roman Kuznetsov 2018-06-17 15:28:09 UTC
bug still present in

Version: 6.1.0.0.beta2+ (x64)
Build ID: fe1a23b5c49c94410a604c8d4a6f50f43d575403
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:libreoffice-6-1, Time: 2018-06-17_06:31:41
Locale: ru-RU (ru_RU); Calc: CL

but there isn't black area instead bottom text. After imports SVG bottom text is just missed.
Comment 11 QA Administrators 2019-06-22 02:50:10 UTC Comment hidden (obsolete)
Comment 12 Grey 2019-07-31 16:05:53 UTC
Has anyone thought to check this Inkscape .svg file in a web browser window? I just did in Firefox 69.0b8 and Chromium 74.0.3729.157 (macOS 10.12.6) and I see the same behaviour as when inserted in a Writer document in LibreOffice 6.3.0.2 (RC2), i.e., only "working text" is rendered, "not working text" is invisible.

I opened the .svg in Inkscape 0.92.4 and it renders "correctly", both text boxes are visible and editable.

I'm thinking it's an Inkscape bug...?
Comment 13 Regina Henschel 2019-07-31 19:49:36 UTC
See linked Inkscape FAQ.
Comment 14 Grey 2019-08-06 10:01:01 UTC
Linked Inkscape FAQ? Where?
Comment 15 Grey 2019-08-06 10:03:14 UTC
Never mind...found it and read it. What a mess.