Download it now!
Bug 64473 - FILESAVE: Simple document Saved as .doc does not open correctly in MSO2013
Summary: FILESAVE: Simple document Saved as .doc does not open correctly in MSO2013
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-11 15:58 UTC by john.pratt
Modified: 2016-02-22 08:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example document (9.00 KB, application/msword)
2013-05-11 15:58 UTC, john.pratt
Details
Example document saved in Office 2010 can be open in 2013 (22.00 KB, application/msword)
2015-01-19 13:03 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description john.pratt 2013-05-11 15:58:46 UTC
Created attachment 79170 [details]
Example document

A simple document (with both highlighted text and background text) loses text when saved as .doc and opened in MS Office 2013 (same file opens correctly in Libreoffice 4.0.2).

Steps to redproduce:
1. Create a document (or used attached), including background colour
2. Save as .doc (from libreOffice)
3. Open in MS Office 2013

Current behaviour: the line which says background disappears

Expected behaviour: document is the same in MS Office.

Workaround: save as .odf works almost perfectly in MS Office.
NB: saving as .docx is better, but then the spacing between lines becomes wrong, but at least no data loss.
Operating System: Windows 7
Version: 4.0.2.2 release
Comment 1 Joel Madero 2013-05-13 15:47:38 UTC
Well it opens perfectly in MSO2010 which is strange. Will test on 2013 shortly
Comment 2 Joel Madero 2013-05-16 17:06:10 UTC
Crazy, I can confirm - this is very weird as it only affects Office 2013 but it's a .doc and not a .docx....I wonder if it is a MSO bug...

As it's confirmed...marking:

New (confirmed)

Major - very simple document losing data for MSO2013 - still concerned this isn't our bug but still quite serious, one way or another it'd be nice if we make it interoperable.

High - Default for major, since the document is so simple and shows the loss of data leaving as High.


Tested on:
Bodhi Linux along with W7 MSO2013
Version: 4.0.2.2

Adding Michael Stahl as I hope he knows something more about this:

Michael - any thoughts here? Seems like MS has done some tricky stuff....again
Comment 3 Timur 2015-01-19 13:03:48 UTC
Created attachment 112463 [details]
Example document saved in Office 2010 can be open in 2013

LO has highlight and both font and paragraph background (changed in LO 4.4.0), while paragraph background in MS seems to be called Shading.

First question here is: how was original example https://bugs.freedesktop.org/attachment.cgi?id=79170 created, which office and version?

Opening example with LO and MS Office 2010 -  the line "background" present, with MS Office 2013 -  the line "background" NOT present (even in the original). Saving that example as .doc with LO -  the line "background" present when open with LO and MS Office 2010.
BUT, saving that example as .doc with MS Office 2010, it can be open with MS Office 2010, 2013, LO -  the line "background" present

Saving as .docx - problem "the spacing between lines becomes wrong" last reproduced in LO 4.1.6, NOT reproduced with 4.3.5.

IMHO, I'd mark this as "WorksForMe".

There's another problem here, reported as Bug 88583 - FILESAVE: Paragraph background in ODT not saved in DOC or DOCX starting from LO 4.4.0.
Comment 4 QA Administrators 2016-02-21 08:38:08 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice 
   (5.0.5 or 5.1.0)  https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and 
   your operating system, and any changes you see in the bug behavior
 
   If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
   a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
   appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-02-21