Bug 88583 - FILESAVE: Paragraph background in ODT not saved in DOC or DOCX
Summary: FILESAVE: Paragraph background in ODT not saved in DOC or DOCX
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta1
Hardware: Other All
: high major
Assignee: Miklos Vajna
QA Contact:
URL:
Whiteboard: target:5.0.0 target:4.4.1
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2015-01-19 12:54 UTC by Timur
Modified: 2016-08-05 19:43 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Test ODT document with background line (10.18 KB, application/vnd.oasis.opendocument.text)
2015-01-19 12:56 UTC, Timur
Details
Test ODT document saved as DOC in LO 4.4.0-beta1 (9.00 KB, application/msword)
2015-01-19 12:58 UTC, Timur
Details
Test ODT document saved as DOCX in LO 4.4.0-beta1 (4.42 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-01-19 12:58 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2015-01-19 12:54:43 UTC
Simple paragraph background from ODT is not saved when document is saved as DOC or DOCX. Problem starting from LO 4.4.0 and confirmed in 4.5.0 master so regression. Tested on Win 64bit.
Comment 1 Timur 2015-01-19 12:56:49 UTC
Created attachment 112460 [details]
Test ODT document with background line
Comment 2 Timur 2015-01-19 12:58:04 UTC
Created attachment 112461 [details]
Test ODT document saved as DOC in LO 4.4.0-beta1
Comment 3 Timur 2015-01-19 12:58:41 UTC
Created attachment 112462 [details]
Test ODT document saved as DOCX in LO 4.4.0-beta1
Comment 4 Kevin Suo 2015-01-19 13:49:37 UTC
CONFIRMED with
Version: 4.4.0.2
Build ID: a3603970151a6ae2596acd62b70112f4d376b990
Locale: zh_CN
Win 7 X86.

Set to NEW.

By the way, when save as DOCX, the "paragraph area gradient" is showing as a text frame when repen in Writer. (This may be another issue and should not be tracked in this bug).
Comment 5 Kevin Suo 2015-01-19 13:56:28 UTC
This is a major bug. It causes format loss when save to DOC/DOCX formats.
Comment 6 Rostislav 'R.Yu.' Okulov 2015-01-23 05:39:58 UTC
# bad: [4a3091e95fa263d3e2dd81e56e83996f0bb12287] source-hash-2b5b04e1e62914bf0902dfd7943cdc44499c47a6
git bisect bad 4a3091e95fa263d3e2dd81e56e83996f0bb12287
# good: [812c4a492375ac47b3557fbb32f5637fc89d60d9] source-hash-dea4a3b9d7182700abeb4dc756a24a9e8dea8474
git bisect good 812c4a492375ac47b3557fbb32f5637fc89d60d9
# good: [5d0dfb8e62ae61a240f8313c594d4560e7c8e048] source-hash-0c6cd530de13f80795881f61064f1bf1dcc4ea81
git bisect good 5d0dfb8e62ae61a240f8313c594d4560e7c8e048
# bad: [7dfacd0b8bd828331d74c0f79de6e8924bc4e6a5] source-hash-f93ce4f7eb90093d0ea3115d0a1c614612676dbd
git bisect bad 7dfacd0b8bd828331d74c0f79de6e8924bc4e6a5
# bad: [1a63057f6378db7c6b8af1171b7b140f7583f246] source-hash-59f84b4a2c082382767f12e0c7a06a3f0b52e721
git bisect bad 1a63057f6378db7c6b8af1171b7b140f7583f246
# good: [3787e4f82e47eaf4fa454afdca671272e50f875b] source-hash-0e09134a4a4cbb0639fc586c560c6fb2765487be
git bisect good 3787e4f82e47eaf4fa454afdca671272e50f875b
# bad: [13c63ebe51bd9151757981f75b62271c00a47bf1] source-hash-5ccb510ef7dd6688b86038b37563583f64107936
git bisect bad 13c63ebe51bd9151757981f75b62271c00a47bf1
# good: [c6f882c644d407425898f336d5395e4e9c2ba8e3] source-hash-2b9ad2ef6bf904a8c2ec94e58644e8a7f7a36ae3
git bisect good c6f882c644d407425898f336d5395e4e9c2ba8e3
# good: [1efd4fa8897d1c45ae8a92b4cb5d74049cc7dec8] source-hash-0d55277947fbc2f92fb9fe40dcfa804dc619c37a
git bisect good 1efd4fa8897d1c45ae8a92b4cb5d74049cc7dec8
# bad: [be4d1e746b8125cb258a718397b8c0deadba09e5] source-hash-be8d4a5d8aa711e8eb9265fd38d17c8290770a0e
git bisect bad be4d1e746b8125cb258a718397b8c0deadba09e5
# bad: [ac0bb760db68647bcda368fc13810850c888a1fa] source-hash-a7e1ffc248bed431693c6d50c02e7c936c67f360
git bisect bad ac0bb760db68647bcda368fc13810850c888a1fa
# first bad commit: [ac0bb760db68647bcda368fc13810850c888a1fa] source-hash-a7e1ffc248bed431693c6d50c02e7c936c67f360

ac0bb760db68647bcda368fc13810850c888a1fa is the first bad commit
commit ac0bb760db68647bcda368fc13810850c888a1fa
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Sat Oct 18 07:12:11 2014 +0000

    source-hash-a7e1ffc248bed431693c6d50c02e7c936c67f360
    
    commit a7e1ffc248bed431693c6d50c02e7c936c67f360
    Author:     Caolán McNamara <caolanm@redhat.com>
    AuthorDate: Tue Jul 1 15:50:28 2014 +0100
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Tue Jul 1 16:43:06 2014 +0100
    
        coverity#706988 Uncaught exception
    
        and
    
        coverity#706989 Uncaught exception
    
        Change-Id: I426ae26f69311effd60c0b60b7f4d677a2e35c80

:100644 100644 dfb919049ad61631d365f9038e78ea6a9bd2057b 554148af8d80ddbf565849328f3bc184847db05e M	ccache.log
:100644 100644 a9084aa481645c85bc8e09936010199b7ee524de 5aa1008cbe0a3bdd212effcbb0192de2ed947cb6 M	commitmsg
:100644 100644 f5c919ded771e0566a1a7ec9fbfcd59a2863e972 5a49acee48ed3dce1fda9141f1f51a55251f15c9 M	make.log
:040000 040000 08cb282a79a428e5cbb828c9a1a84a2808d3dc66 4301dffd0df84a13f6f81e4f0fb67f53900889dd M	opt
Comment 7 Matthew Francis 2015-01-23 15:19:35 UTC
This seems partly related to bug 88337, but the symptoms and sequence of commits are both slightly different.

The loading of background colours from attachment 112460 [details] was broken completely by commit 7d9bb549d498d6beed2c4050c402d09643febdfa. The loading was then fixed by commit 3350fabd23859eb5fdbe77c6db9248866d4e2995, but since only some of the colours are saved to .docx

Adding Cc: to vmiklos@collabora.co.uk


commit 7d9bb549d498d6beed2c4050c402d09643febdfa
Author:     Armin Le Grand <alg@apache.org>
AuthorDate: Mon Jun 2 15:00:50 2014 +0000
Commit:     Miklos Vajna <vmiklos@collabora.co.uk>
CommitDate: Tue Jul 1 13:30:09 2014 +0200

    Related: #i124638# Second step of DrawingLayer FillAttributes...
    
    for Writer objects, now added support for Paragraph and PageStyle (including
    Header and Footer) for direct attributes and style attributes
    
    (cherry picked from commit cc25c58f7052827bfebdc9fbeec668c8fa29ed1b)



commit 3350fabd23859eb5fdbe77c6db9248866d4e2995
Author: Miklos Vajna <vmiklos@collabora.co.uk>
Date:   Mon Jun 30 13:46:04 2014 +0200

    SwXAutoStyle::GetPropertyValues_Impl: fix handling of CharAutoStyleName
    
    Without this, all character properties defined inside automatic styles
    are ignored.
    
    Change-Id: I3c25f5d36503a9f40834dd88573a40c34380b967
Comment 8 Miklos Vajna 2015-01-30 17:54:17 UTC
We'll need something like 84c40768f8acb0342dcfa223133497f57620fc14 that fixed the same problem for page backgrounds.
Comment 9 Commit Notification 2015-01-31 09:59:00 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=60cdeb2d441a6bf5c55f511f574b2b9dd598fbb8

tdf#88583 MSWordExportBase: fix handling of paragraph background color

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Timur 2015-02-03 15:57:05 UTC
Please make a backport for 4.4, which has a long time to go yet.
Comment 11 Commit Notification 2015-02-05 10:46:22 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=776a0b7bae60215996e7d5a0f73a24417414b9bb&h=libreoffice-4-4

tdf#88583 MSWordExportBase: fix handling of paragraph background color

It will be available in 4.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2015-02-09 16:02:33 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5b48d5e25c8e7918f4669195144afb1fae049d41&h=libreoffice-4-4

Related: tdf#88583 writerfilter: import paragraph color as fill attributes

It will be available in 4.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2015-02-11 15:09:44 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3e44fcca87fc8e1354d1d735f3a10e388f2f1d0b&h=libreoffice-4-4

Related: tdf#88583 RTF export: need to take care of fill attributes when ...

It will be available in 4.4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Robinson Tryon (qubit) 2015-03-31 16:02:21 UTC
(In reply to Commit Notification from comment #13)
> Miklos Vajna committed a patch related to this issue.
> It has been pushed to "libreoffice-4-4":

Whiteboard: (removing) backportRequest:4.4
Comment 15 Robinson Tryon (qubit) 2015-12-17 08:45:17 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]