Bug Hunting Session
Bug 88337 - ODF import: Page background image is not shown
Summary: ODF import: Page background image is not shown
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.2 rc
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: odf target:5.0.0 target:4.4.3
Keywords: bibisected, bisected, regression
: 89193 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-12 19:55 UTC by Regina Henschel
Modified: 2015-12-17 08:43 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
document with page background (50.70 KB, application/vnd.oasis.opendocument.text)
2015-01-12 19:55 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2015-01-12 19:55:49 UTC
Created attachment 112138 [details]
document with page background

Open the attached document in LibreOffice 4.2 and in current developer version. Notice, that you see a background image tiled "sky" in version 4.2 but not in current version.

I see the image in Version: 4.2.5.2
Build ID: 6ff819b65674ae6c83f3cbab9e4a4c2b292a7a94

I see no image in Version: 4.5.0.0.alpha0+
Build ID: 5b829710d65310c6082c2c65ec1239515e319a8e
TinderBox: Win-x86@39, Branch:master, Time: 2014-12-02_06:39:26
Locale: de_DE
Comment 1 Robinson Tryon (qubit) 2015-01-14 22:22:04 UTC
TESTING with Ubuntu 14.04

(In reply to Regina Henschel from comment #0)
REPRO Steps:
> Open [attachment 112138 [details]] in LibreOffice 4.2 and in current developer
> version. Notice, that you see a background image tiled "sky" in version 4.2
> but not in current version.

LO 4.4.0.2 rc: I see a bunch of text in the background

LO 4.2.6.3: I see a blue/white cloudy background image

Status -> NEW
Hardware -> (Generalize)
Whiteboard -> bibisectRequest
Keywords -> regression
Comment 2 Michael Weghorn 2015-01-21 15:16:11 UTC
bibisect result:

ac0bb760db68647bcda368fc13810850c888a1fa is the first bad commit
commit ac0bb760db68647bcda368fc13810850c888a1fa
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Sat Oct 18 07:12:11 2014 +0000

    source-hash-a7e1ffc248bed431693c6d50c02e7c936c67f360
    
    commit a7e1ffc248bed431693c6d50c02e7c936c67f360
    Author:     Caolán McNamara <caolanm@redhat.com>
    AuthorDate: Tue Jul 1 15:50:28 2014 +0100
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Tue Jul 1 16:43:06 2014 +0100
    
        coverity#706988 Uncaught exception
    
        and
    
        coverity#706989 Uncaught exception
    
        Change-Id: I426ae26f69311effd60c0b60b7f4d677a2e35c80

:100644 100644 dfb919049ad61631d365f9038e78ea6a9bd2057b 554148af8d80ddbf565849328f3bc184847db05e M	ccache.log
:100644 100644 a9084aa481645c85bc8e09936010199b7ee524de 5aa1008cbe0a3bdd212effcbb0192de2ed947cb6 M	commitmsg
:100644 100644 f5c919ded771e0566a1a7ec9fbfcd59a2863e972 5a49acee48ed3dce1fda9141f1f51a55251f15c9 M	make.log
:040000 040000 08cb282a79a428e5cbb828c9a1a84a2808d3dc66 4301dffd0df84a13f6f81e4f0fb67f53900889dd M	opt

--

# bad: [4a3091e95fa263d3e2dd81e56e83996f0bb12287] source-hash-2b5b04e1e62914bf0902dfd7943cdc44499c47a6
# good: [812c4a492375ac47b3557fbb32f5637fc89d60d9] source-hash-dea4a3b9d7182700abeb4dc756a24a9e8dea8474
git bisect start 'latest' 'oldest'
# good: [5d0dfb8e62ae61a240f8313c594d4560e7c8e048] source-hash-0c6cd530de13f80795881f61064f1bf1dcc4ea81
git bisect good 5d0dfb8e62ae61a240f8313c594d4560e7c8e048
# bad: [7dfacd0b8bd828331d74c0f79de6e8924bc4e6a5] source-hash-f93ce4f7eb90093d0ea3115d0a1c614612676dbd
git bisect bad 7dfacd0b8bd828331d74c0f79de6e8924bc4e6a5
# bad: [1a63057f6378db7c6b8af1171b7b140f7583f246] source-hash-59f84b4a2c082382767f12e0c7a06a3f0b52e721
git bisect bad 1a63057f6378db7c6b8af1171b7b140f7583f246
# good: [3787e4f82e47eaf4fa454afdca671272e50f875b] source-hash-0e09134a4a4cbb0639fc586c560c6fb2765487be
git bisect good 3787e4f82e47eaf4fa454afdca671272e50f875b
# bad: [13c63ebe51bd9151757981f75b62271c00a47bf1] source-hash-5ccb510ef7dd6688b86038b37563583f64107936
git bisect bad 13c63ebe51bd9151757981f75b62271c00a47bf1
# good: [c6f882c644d407425898f336d5395e4e9c2ba8e3] source-hash-2b9ad2ef6bf904a8c2ec94e58644e8a7f7a36ae3
git bisect good c6f882c644d407425898f336d5395e4e9c2ba8e3
# good: [1efd4fa8897d1c45ae8a92b4cb5d74049cc7dec8] source-hash-0d55277947fbc2f92fb9fe40dcfa804dc619c37a
git bisect good 1efd4fa8897d1c45ae8a92b4cb5d74049cc7dec8
# bad: [be4d1e746b8125cb258a718397b8c0deadba09e5] source-hash-be8d4a5d8aa711e8eb9265fd38d17c8290770a0e
git bisect bad be4d1e746b8125cb258a718397b8c0deadba09e5
# bad: [ac0bb760db68647bcda368fc13810850c888a1fa] source-hash-a7e1ffc248bed431693c6d50c02e7c936c67f360
git bisect bad ac0bb760db68647bcda368fc13810850c888a1fa
# first bad commit: [ac0bb760db68647bcda368fc13810850c888a1fa] source-hash-a7e1ffc248bed431693c6d50c02e7c936c67f360
Comment 3 Matthew Francis 2015-01-23 09:16:10 UTC
The behaviour changed as of the below commit.

Adding Cc: to vmiklos@collabora.co.uk; Any chance you could take a look at this? Thanks


commit 7d9bb549d498d6beed2c4050c402d09643febdfa
Author:     Armin Le Grand <alg@apache.org>
AuthorDate: Mon Jun 2 15:00:50 2014 +0000
Commit:     Miklos Vajna <vmiklos@collabora.co.uk>
CommitDate: Tue Jul 1 13:30:09 2014 +0200

    Related: #i124638# Second step of DrawingLayer FillAttributes...
    
    for Writer objects, now added support for Paragraph and PageStyle (including
    Header and Footer) for direct attributes and style attributes
    
    (cherry picked from commit cc25c58f7052827bfebdc9fbeec668c8fa29ed1b)
Comment 4 V Stuart Foote 2015-03-04 16:33:43 UTC

*** This bug has been marked as a duplicate of bug 86578 ***
Comment 5 Michael Stahl (CIB) 2015-04-14 15:44:03 UTC
this is not a duplicate of bug 86578, it's just caused by the same commit

fixed on master
Comment 6 Michael Stahl (CIB) 2015-04-14 15:46:32 UTC
*** Bug 89193 has been marked as a duplicate of this bug. ***
Comment 7 Michael Stahl (CIB) 2015-04-14 16:12:12 UTC
bot is AWOL again, adding manually:

added Regina's bugdoc for the unit test as commit c31d87b525dd974e018892c98aed4fdb893c3469

fixed on master by commit 65a56636a68451d15499a37c2d5bd9efb71b1279
Comment 8 Commit Notification 2015-04-14 20:05:01 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d2c490fb9f4b2b6b63b82c4ba26df9a3672f9d55&h=libreoffice-4-4

tdf#88337 tdf#89193: sw: add missing SwXPageStyle properties

It will be available in 4.4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2015-04-16 21:10:03 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=662b368fd204066f2668c27e18f11ef9434d674a

tdf#88337 tdf#89193: sw: add missing SwXPageStyle properties

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Robinson Tryon (qubit) 2015-12-17 08:43:56 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]