Download it now!
Bug 90054 - Text autocolor incorrect?
Summary: Text autocolor incorrect?
Status: RESOLVED DUPLICATE of bug 87922
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2015-03-17 11:58 UTC by eamonfitzpatrick
Modified: 2015-12-15 11:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
corrupt heading (20.29 KB, application/vnd.oasis.opendocument.text)
2015-03-17 11:58 UTC, eamonfitzpatrick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description eamonfitzpatrick 2015-03-17 11:58:51 UTC
Created attachment 114149 [details]
corrupt heading

I have checked this on windows and osx.

The below document has a heading with white text on a black background (automatic from memory).

It still shows as white on black in 4.2, openoffice, google drive viewer and microsoft word.

However in the 4.4 line it appears black on black
Comment 1 Buovjaga 2015-03-21 12:28:38 UTC
Confirmed the problem in 4.4 & 4.5 and no problem in 4.2.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI

Version: 4.5.0.0.alpha0+
Build ID: 181feb38d95e25980b96c2f6802cc906410abb13
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-03-19_23:38:28
Locale: fi_FI

Ubuntu 14.10 64-bit 
Version: 4.4.1.2
Build ID: 40m0(Build:2)
Locale: en_US

Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
Comment 2 Matthew Francis 2015-03-25 12:16:49 UTC
So initially there is white text on black, which later become black text on white at (1), then black text on black at (2).

Adding Cc: to vmiklos@collabora.co.uk; Could you possibly take a look at this? Thanks
(I note that this is the same pair of commits involved in bug 88583, but the issue for this document still persists in current master)

(1)
    commit 7d9bb549d498d6beed2c4050c402d09643febdfa
    Author:     Armin Le Grand <alg@apache.org>
    AuthorDate: Mon Jun 2 15:00:50 2014 +0000
    Commit:     Miklos Vajna <vmiklos@collabora.co.uk>
    CommitDate: Tue Jul 1 13:30:09 2014 +0200
    
        Related: #i124638# Second step of DrawingLayer FillAttributes...

(2)
    commit 3350fabd23859eb5fdbe77c6db9248866d4e2995
    Author:     Miklos Vajna <vmiklos@collabora.co.uk>
    AuthorDate: Mon Jun 30 13:46:04 2014 +0200
    Commit:     Miklos Vajna <vmiklos@collabora.co.uk>
    CommitDate: Tue Jul 1 13:30:12 2014 +0200
    
        SwXAutoStyle::GetPropertyValues_Impl: fix handling of CharAutoStyleName
Comment 3 Miklos Vajna 2015-08-11 08:25:05 UTC
After fixing bug 87922, this renders correctly, too -- marking as a duplicate. The fix for the bug is in my 5.0 and 4.4 backport queue, just a matter of time.

*** This bug has been marked as a duplicate of bug 87922 ***
Comment 4 Robinson Tryon (qubit) 2015-12-15 11:03:40 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]