Download it now!
Bug 97090 - FILESAVE: Paragraph White Fill added to some tables in DOCX export
Summary: FILESAVE: Paragraph White Fill added to some tables in DOCX export
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:5.3.0 target:5.2.2
Keywords: bisected, preBibisect
: 102905 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-01-13 05:06 UTC by Luke
Modified: 2018-08-06 20:08 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document (29.20 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-01-13 05:06 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2016-01-13 05:06:10 UTC
Created attachment 121892 [details]
Test document

When testing Bug 95755, I discovered that roundtripping the file will add a Paragraph->Area->Fill: White to the table. 

Steps to reproduce:
1. Open WORD_EXAMPLE (1).docx 
2. Save as DOCX
3. Close and reopen

tested with Version: 5.2.0.0.alpha0+
Build ID: 8dbfc413b1603c814cecf5306238c6144185671f

I'm not sure if this is a native MSO document, so it may a low priority corner case.
Comment 1 Buovjaga 2016-01-25 11:26:00 UTC
Repro.

In 4.3 the backgrounds of the affected cells are white already on opening, so this is actually progress :)

Win 7 Pro 64-bit, Version: 5.0.4.2 (x64)
Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: 6b65a0e83c4798f117be61af91dbaebdc85e94b7
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-01-21_03:41:08
Locale: fi-FI (fi_FI)
Comment 2 Justin L 2016-08-04 19:02:16 UTC
Later in 5.2, it has reverted back to importing/opening with a white paragraph fill again due to commit https://cgit.freedesktop.org/libreoffice/core/commit/?id=eae2331f83bd58bacccd898d60f6c5f54856c036.

Specifically from:
+if (sConvertedStyleName != "Standard")
    StyleSheetTable_Impl::SetPropertiesToDefault(xStyle);
Comment 3 Luke 2016-08-05 02:25:26 UTC
Miklos and Justin,

We have 2 separate issues now.

1) original FILESAVE: round-trip bug 

2) New FILEOPEN: Regression from https://cgit.freedesktop.org/libreoffice/core/commit/?id=eae2331f83bd58bacccd898d60f6c5f54856c036.

Do you want to track them both here, reopen Bug 95755 for 2), or file a new bug report for 2)?
Comment 4 Mike Kaganski 2016-08-05 03:41:51 UTC
(In reply to Luke from comment #3)
> Do you want to track them both here, reopen Bug 95755 for 2), or file a new
> bug report for 2)?

Bug 95755 shouldn't be reopened for this, because this issue had never been its subject.
Comment 5 Justin L 2016-08-05 05:16:47 UTC
(In reply to Luke from comment #3)
Just track everything in one bug for now.  Comment #2 was just to help the developers land in the right place.

The "white paragraph fill on import" was probably inherited from OOo - it goes back to last36onmaster at least - which was the earliest I could test on 16.04.

The spot where the import kept the paragraph as no-fill came from
commit 24077b2d52ab3d0fd0db5afb25d8b94b62386e3e
https://cgit.freedesktop.org/libreoffice/core/commit/?id=24077b2d52ab3d0fd0db5afb25d8b94b62386e3e
Author:     Miklos Vajna <vmiklos@collabora.co.uk>
CommitDate: Sun Feb 1 01:48:38 2015 +0100
writerfilter: import paragraph color as fill attributes
Comment 6 Justin L 2016-08-05 17:47:44 UTC
proposed fix https://gerrit.libreoffice.org/#/c/27915
Comment 7 Commit Notification 2016-08-15 06:49:36 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2a174c2f6fd58a31eb150b84de83e5ba1c4d3fed

tdf#97090 writerfilter - don't fill_SOLID with auto color

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Luke 2016-08-16 07:32:02 UTC
Both issues have been fixed. Verified with Version: 5.3.0.0.alpha0+ (x64).

Thank you Justin!
Comment 9 Commit Notification 2016-08-16 11:51:21 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=834ae34d7f16f37078bf0065af8bff29f9d5c422&h=libreoffice-5-2

tdf#97090 writerfilter - don't fill_SOLID with auto color

It will be available in 5.2.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Buovjaga 2018-08-06 20:08:48 UTC
*** Bug 102905 has been marked as a duplicate of this bug. ***