Bug Hunting Session
Bug 102905 - Saving an odt file as OOXML gives white Area color fill to Text body paragraph style
Summary: Saving an odt file as OOXML gives white Area color fill to Text body paragrap...
Status: RESOLVED DUPLICATE of bug 97090
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Paragraph
  Show dependency treegraph
 
Reported: 2016-10-01 03:22 UTC by Franklin Weng
Modified: 2018-08-06 20:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The Original ODT file (20.52 KB, application/vnd.oasis.opendocument.text)
2016-10-01 03:22 UTC, Franklin Weng
Details
Saved OOXML file (13.79 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-10-01 03:23 UTC, Franklin Weng
Details
The original ODT file after saving as docx (20.52 KB, application/vnd.oasis.opendocument.text)
2016-10-01 03:25 UTC, Franklin Weng
Details
Original odt saved from LO 6.0.x (12.00 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-07-26 21:58 UTC, Gabor Kelemen
Details
Screenshot of the original and the LO6-saved docx (400.42 KB, image/png)
2018-07-26 22:47 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Franklin Weng 2016-10-01 03:22:12 UTC
Created attachment 127757 [details]
The Original ODT file

For the screenshot please reference

http://imgur.com/a/LcCUa

The attached file is a normal ODT file, with fonts from Microsoft (but also installed in my Kubuntu box).  

The original odt file (as attached file):
http://imgur.com/HjqVvbW

Use Save As... to save this file in OOXML format:
http://imgur.com/sv3C5io

Something wrong with saved OOXML file (will attach as the second file):
http://imgur.com/YTSkA50

The original file should not have been changed, but after closing the window and reopen the original file, it was changed (will attach as the third file):
http://imgur.com/wCUcONB
Comment 1 Franklin Weng 2016-10-01 03:23:45 UTC
Created attachment 127758 [details]
Saved OOXML file

The saved OOXML (docx) file, whose layout/display is not correctly either
Comment 2 Franklin Weng 2016-10-01 03:25:02 UTC
Created attachment 127759 [details]
The original ODT file after saving as docx

Since I'm using Save As...  the original file should not have been changed.

However after closing the window and reopen it, the original ODT file was changed.
Comment 3 Buovjaga 2016-10-13 05:51:34 UTC
The paragraph styles get a white Area color fill. Thus, this is related to bug 92524, although in that one, the paragraph styles also get a white *highlight*.

For the other problem, please create a separate report. There can be only one issue per bug report.

I didn't quite understand the font problem, so when you create a new issue, try to somehow make it more clear, what the problem is.

Win 7 Pro 64-bit Version: 5.3.0.0.alpha0+
Build ID: e2f6c7f0d0cc14f851d7028ff846c5dc658a81c6
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-10-10_23:08:02
Locale: fi-FI (fi_FI); Calc: group
Comment 4 QA Administrators 2018-06-26 02:43:30 UTC Comment hidden (obsolete, spam)
Comment 5 Gabor Kelemen 2018-07-26 21:58:11 UTC
Created attachment 143796 [details]
Original odt saved from LO 6.0.x

The white table text background no longer happens, I think this was fixed in bug #97090.
Comment 6 Gabor Kelemen 2018-07-26 22:47:45 UTC
Created attachment 143797 [details]
Screenshot of the original and the LO6-saved docx

Pretty similar looks now.
There is a bit of font difference on page 2 (not shown on this), but that's probably just my system lacking the relevant fonts :).
I'd suggest to close this as a duplicate.
Comment 7 Buovjaga 2018-08-06 20:08:48 UTC
No comment from Franklin, but let's close.

*** This bug has been marked as a duplicate of bug 97090 ***