Bug 64555 - FORMATTING: When I open xlsx document and save changes, show me border cells with width 6 pixels
Summary: FORMATTING: When I open xlsx document and save changes, show me border cells ...
Status: RESOLVED DUPLICATE of bug 52578
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-13 16:50 UTC by Rodrigo Hernandez
Modified: 2013-06-07 13:47 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
the result when open the saved worksheet (16.59 KB, image/png)
2013-05-13 16:55 UTC, Rodrigo Hernandez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rodrigo Hernandez 2013-05-13 16:50:42 UTC
Problem description: 

When I open xlsx document and save changes, show me border cells with width 6 pixels

Expected behavior:
when I open excel document that show me border cells with width 1 pixel
Operating System: Windows 7
Version: 4.0.2.2 release
Comment 1 Rodrigo Hernandez 2013-05-13 16:52:48 UTC
it's ocurred when on cells from table with borders external and internal painted
Comment 2 Rodrigo Hernandez 2013-05-13 16:55:58 UTC
Created attachment 79263 [details]
the result when open the saved worksheet

This is the result when open the saved worksheet
Comment 3 m.a.riosv 2013-05-13 21:55:35 UTC
Hola Rodrígo, thanks for reporting.

Please do a try changing the Anti-Aliasing in Menu/Tools/Options/LibreOffice/View.
Comment 4 ign_christian 2013-05-14 03:51:26 UTC
confirmed this bug on LO 4.0.3.3 (Win7 Home Premium 32bit) 

Steps to reproduce:
1. Open new blank spreadsheet
2. Choose & click any cell > right click > Format Cells > Borders
3. Type 1 under 'Width' > choose & click 'Set All Four Borders' under 'Line arrangement - Default' > OK
4. Save as *.xlsx
5. Close & reopen that file

See that cell will have 4pt width (right clicking the cell > Format Cells > Borders)
Enabling or disabling 'Anti-aliasing' have no effect

I think this bug exists since LO 3.6
Comment 5 Owen Genat (retired) 2013-06-04 06:50:40 UTC
I believe this to be a duplicate of bug #52578. Can someone please confirm if the description in the title of that bug and my comment at https://bugs.freedesktop.org/show_bug.cgi?id=52578#c5 describe what is occurinng here? Comment #4 would seem to indicate that it is. Thanks.
Comment 6 ign_christian 2013-06-06 12:42:00 UTC
In my opinion it's same. XLSX can't remember border width correctly (file save problem).
Comment 7 Paijo 2013-06-07 03:38:50 UTC
I Confirm that this bug exist in LO version 4.0.2 (tested both Ubuntu 13.04 and Ubuntu 12.04).

Mine have 4pt thick border.

This bug similar/duplicate to bug 52578
Comment 8 ign_christian 2013-06-07 04:36:24 UTC
> When I open xlsx document and save changes, show me border cells with width
> 6 pixels

Reporter's description told something different with others: 6pt not 4 pt?

@Rodrigo: is it possible if you attach your spreadsheet showing that problem?
Comment 9 Owen Genat (retired) 2013-06-07 11:53:24 UTC
Thanks for confirming. The original description stated "6 pixels" rather than "6pt" and given approximately 96 pixels per inch on screen and 72pt per inch I think that effectively indicates the same value. I am therefore closing as a duplicate of the indicated bug.

*** This bug has been marked as a duplicate of bug 52578 ***
Comment 10 ign_christian 2013-06-07 13:47:28 UTC
> Thanks for confirming. The original description stated "6 pixels" rather
> than "6pt" and given approximately 96 pixels per inch on screen and 72pt per
> inch I think that effectively indicates the same value. I am therefore
> closing as a duplicate of the indicated bug.

Ups..I've just know that :) So 6 pixels similar to 4 pt
Thanks for your explanation