Download it now!
Bug 64559 - Kashida appears randomly between non-justified Arabic letters/words
Summary: Kashida appears randomly between non-justified Arabic letters/words
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0
Keywords:
Depends on: HarfBuzz
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 19:26 UTC by Ahmad Harthi
Modified: 2016-11-06 18:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Different fonts have different results. (red arrows points to kashidas) (72.82 KB, image/png)
2013-05-13 19:26 UTC, Ahmad Harthi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ahmad Harthi 2013-05-13 19:26:25 UTC
Created attachment 79268 [details]
Different fonts have different results. (red arrows points to kashidas)

Steps to reproduce:
1. Open a new Writer document.
2. Type in Arabic any sentence.
3. Change font to Simplified Naskh or KACST One
4. Change the font size randomly

Expected behavior:
Kashidas should not appear at all in the non-justified paragraphs, and should appear in proper places in justified paragraphs fdo#35320.

This is an old regression, I don't recall when but since OOo!
Comment 1 tommy27 2013-08-23 16:14:45 UTC
(In reply to comment #0)
> 
> ... snip...
> 
> This is an old regression, I don't recall when but since OOo!

so version field should be set to 3.3.0 (first LibO release ever).

I remove you from ASSIGNED TO... that field should indicate the developer that will fix the bug, not the use reporting it.
Comment 2 tommy27 2013-08-23 16:15:55 UTC
please, tell us if the bug is still present in recent 4.0.5 or 4.1.0 releases
Comment 3 tommy27 2013-08-23 16:18:06 UTC
ooopsss.... sorry Ahmad... I did not know that you were a developer.
reverting status to ASSIGNED.
Comment 4 mahfiaz 2016-08-04 17:30:32 UTC
Seems like Ahmad did not take it up.

Can anyone confirm it's still a bug? If not, it's going to be closed.