Download it now!
Bug 64565 - Libre Office unity menus has delay when first opened on Ubuntu 13.04
Summary: Libre Office unity menus has delay when first opened on Ubuntu 13.04
Status: VERIFIED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-05-13 21:47 UTC by Ljiljan
Modified: 2013-05-22 19:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ljiljan 2013-05-13 21:47:38 UTC
Problem description: 

I've just update my libreoffice 4.0.2.2 to 4.0.3.3.... When I start Writer, Impress or Calc, the first time I click on any main menu it does not show submenus automatically (I recorded problem using RecordMyDesktop and uploaded to http://www.youtube.com/watch?v=uNQ0r4YVITU).

I heard that menu issues are realted to Unity. So is it Ubuntu or LibreOffice problem? And any idea how to fix it?

I am using Ubuntu 13.04 and Libre Office 4.0.3.3. (this didn't happen in 4.0.2.2.)..

Operating System: Ubuntu
Version: 4.0.3.3 release
Last worked in: 4.0.2.2 release
Comment 1 Björn Michaelsen 2013-05-14 08:03:14 UTC
Which LibreOffice version do you use _exactly_? Full version number and source please (official repo? ppa? upstream? full debian version in case of a packaged version please)
Comment 2 Björn Michaelsen 2013-05-14 10:07:24 UTC
Trying this with 4.0.3.2 from the ppa, I see this ... somewhat: When I create a new table and directly go immediately to the table->delete menu it is still disabled, but not when doing it slower or when rolling to another menu, so this is likely just a latency issue: the menu just isnt updated quick enough.
Comment 3 Björn Michaelsen 2013-05-14 10:08:25 UTC
whops, last comment was for bug 64560, which is likely related.
Comment 4 Ljiljan 2013-05-14 18:05:33 UTC
Version 4.0.3.3 (Build ID: 400m0(Build:3))

I run in cmd "sudo add-apt-repository ppa:libreoffice/libreoffice-4-0"

and then went to Software Updater... 87 MB was downloaded and installed... 

how can I try to reinstall it?
Comment 5 Björn Michaelsen 2013-05-14 23:06:37 UTC
@Ljijan: On which Ubuntu version?
Comment 6 Ljiljan 2013-05-15 06:13:58 UTC
Ubuntu 13.04

I had Ubuntu 12.10 and when 13.04 was released, I updated to 13.04. 

Some additional info (if it matters?)

In Ubuntu 12.10 I used LibreOffice 4.0 (installed from official LO PPA), but it didn't integrate well with Unity launcher... (all programs were grouped under the one icon)... then  removed it using Synaptic Package Manager (I marked all LibreOffice Packages  for Complete Removal) and then reinstalled it using Ubuntu Software Center... when new version of Ubuntu was relased, I update my Ubuntu to 13.04 and new Libre Office 4.0.2.2 was already there... no problems intead of menu hover problem that is already reported.  And few days ago I updated my Libre Office to 4.0.3.3. using LO PPA.

Will it help to reinstall LO?
Comment 7 Björn Michaelsen 2013-05-15 06:32:55 UTC
This is a sideeffect of the fix for:

 https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1085169

because exporting the menu to unity the first time takes time. Note that the menu shows up after a short delay even in your video.

Same fix is also on master and will be released with 4.1.x. The question is still open if this will be SRUed to raring though.

updating bug summary.
Comment 8 Björn Michaelsen 2013-05-15 06:33:26 UTC
closing as WONTFIX for now upstream.
Comment 9 Ljiljan 2013-05-21 07:05:58 UTC
any suggestion what should I do? should I unistall 4.0.3.3 and install 4.0.2.2.?
Comment 10 mmasroorali 2013-05-21 10:43:56 UTC
Same problem here in Ubuntu 12.04. Submenus do not appear at all. In Ubuntu 13.04, submenus appear after a while. 

Both machines are using PPA. Upgraded to the latest version.
Comment 11 Björn Michaelsen 2013-05-21 13:15:10 UTC
See https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1182082/comments/25

Rico will rebuild the 12.04 build without the patch. I will likely do the same and not SRU this to 13.04. Still this will be released with upstream LibreOffice 4.1 (introducing the delay and but fixing the 'menus dead after print preview').
Comment 12 Ljiljan 2013-05-22 19:58:58 UTC
I don't have problems any more. Ubuntu updated Libre Office to 4.0.3.3 again (even though it already was 4.0.3.3.)  and now no delays to submenus. Update was provided today. 

I don't understand what happened, but the problem is solved...