Download it now!
Bug 64584 - Vertical writing mode is not functional.
Summary: Vertical writing mode is not functional.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: Other All
: medium critical
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.1.0
Keywords:
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-05-14 13:31 UTC by Kohei Yoshida
Modified: 2013-05-16 05:50 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kohei Yoshida 2013-05-14 13:31:19 UTC
When the text direction is "right-to-left (vertical)" (vertical layout), Writer won't accept any key input at all, and on each key stroke, the displayed area flickers a bit.

To enable vertical layout, you need to 

1. check "Show UI elements for East Asian writings" in the Options dialog (Language Settings - Languages, under Enhanced language support), and 

2. go to Format - Page, and change the text direction from "left-to-right (horizontal" to "right-to-left (vertical)".

Once done, try to type any characters, it won't be accepted.
Comment 1 Kohei Yoshida 2013-05-14 13:32:26 UTC
Confirming.
Comment 2 Jorendc 2013-05-15 09:40:42 UTC
Hi Kohei,

I was busy doing a bisect for another bug. I have now Version: 4.1.0.0.alpha0+ Build ID: b993c5591e965de3b9e95e32007ea4231b2997d (build of 2013-04-29 08:44:59), so if I can reproduce it with current (latest master version now), we have a quite narrow range. I'll try to post my findings after I build the latest master now.

Kind regards,
Joren
Comment 3 Jorendc 2013-05-15 10:59:26 UTC
(In reply to comment #2)
> Hi Kohei,
> 
> I was busy doing a bisect for another bug. I have now Version:
> 4.1.0.0.alpha0+ Build ID: b993c5591e965de3b9e95e32007ea4231b2997d (build of
> 2013-04-29 08:44:59)

-> I did NOT reproduce this behavior with that version.
Comment 4 Caolán McNamara 2013-05-15 16:33:41 UTC
looks like http://cgit.freedesktop.org/libreoffice/core/commit/?id=69c52bc5b7973a2e414209470f5bf9b66dcc4f30 broke this. perhaps some x in there should be a y
Comment 5 Commit Notification 2013-05-15 19:45:29 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=78123a504b5215d061935d7b2771ba51e68cae0e

Resolves: fdo#64584 revert convert Point::X/Y to Point::set/getX/Y



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Miklos Vajna 2013-05-16 05:50:46 UTC
Ah yes, sorry about that. I needed it primarily for some debugging -- when I need it next time, I'll do it in smaller chunks and will definitely test vertical layout. ;-)