Bug 64635 - EDITING: Edit/find uses advanced options (ex. "Similarity search") from Find & Replace dialog
Summary: EDITING: Edit/find uses advanced options (ex. "Similarity search") from Find ...
Status: RESOLVED DUPLICATE of bug 62601
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-15 13:36 UTC by To Do
Modified: 2013-05-28 18:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document (50.54 KB, application/vnd.oasis.opendocument.text)
2013-05-17 13:53 UTC, To Do
Details
Edit problem description (36.53 KB, image/png)
2013-05-18 18:02 UTC, ign_christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description To Do 2013-05-15 13:36:45 UTC
Problem description: 
Sometimes, while searching, "find" finds other text different from the search term.
Steps to reproduce:
1. Find some text
2. Again
3. and again. At some point thr bug appears.

The problem is more serious when you use Find and replace because it replaces text which was not inteded to be replaced.              
Operating System: Ubuntu
Version: 4.0.3.3 release
Last worked in: 3.6.6.2 release
Comment 1 Michael Stahl (CIB) 2013-05-17 13:39:50 UTC
cannot reproduce the problem.

please attach a sample document that demonstrates the problem,
and specify which word exactly you are searching for that
results in erroneous results.

also, do you use the find-box (Ctrl+F) to search or
the "Find and Replace" dialog?
Comment 2 To Do 2013-05-17 13:53:04 UTC
Created attachment 79463 [details]
Test document

Ctrl + F to search "Egypte" finds "Egypt". Again searching for "Prays" finds "says"
Comment 3 To Do 2013-05-17 13:57:55 UTC
The problem is present also with the Find and replace dialog.

As a temporary solution I'm using the alternative search and replace extension.
Comment 4 ign_christian 2013-05-17 16:01:33 UTC
not reproducible on LO 4.0.3.3 (Win7 Home Premium 32bit)
Comment 5 To Do 2013-05-17 16:08:51 UTC
I tried renaming my profile folder and in actual fact, without any customisations or extensions the problem disappears.

Perhaps the problem is due to a conflicting extension.
Comment 6 ign_christian 2013-05-17 16:16:02 UTC
Please change status to: RESOLVED NOTABUG if you think it's not a bug
Comment 7 To Do 2013-05-18 09:19:05 UTC
I found out what the problem was.

I had used "Similarity search" in the past and the option remained active in all my future searches. This should not be the case. Once an advanced option is used, I think it would be useful to reset then to default when a second search is done or at least when the application is closed.

One other option is to show which advanced options are enabled, even if the advanced options button is not pressed.

Furthermore, this advanced option was being applied even when pressing ctrl + f. There is no clue to what advanced options are being used without knowing. In my opinion, ctrl + f should do a simple search without taking into consideration any advanced options previously selected.
Comment 8 To Do 2013-05-18 12:46:14 UTC
I would like to edit the description of this bug but cannot find how to do it here.

Anyway, here's my modified description as a comment:

Problem description: 
If "Similarity search" is used in the advanced find and replace dialog, the simple "find" command uses this option as well.

Steps to reproduce:
1. Open the find and replace dialog (ctrl + h), more options, similarity search.
2. Type something and click find.
3. Close the dialog box.
4. Open the find dialog (ctrl + f) and search for something.

Notice that "Similarity search" is still enabled.

Operating System: Ubuntu
Version: 4.0.3.3 release
Last worked in: 3.6.6.2 release
Comment 9 ign_christian 2013-05-18 14:07:34 UTC
To edit Problem Description: simply click "(edit)" on the right problem description at the top of this page

Confirmed..reproducible with LO 4.0.3.3 (Win7 32bit) -> enabling "Find & Replace" always remembered, even after closing & reopening LO

Similar to Bug 62601
Comment 10 ign_christian 2013-05-18 14:09:33 UTC
(In reply to comment #9)

Sorry: 
> Confirmed..reproducible with LO 4.0.3.3 (Win7 32bit) -> enabling 
"Similarity Search" in "Find &
> Replace" always remembered, even after closing & reopening LO
Comment 11 To Do 2013-05-18 14:51:49 UTC
Sorry, but I don't see any [edit] near the description, only reply and [-].
Comment 12 ign_christian 2013-05-18 18:02:53 UTC
Created attachment 79503 [details]
Edit problem description

Hi To Do.. 

Please see attachment, perharps you need this in another bug. Seems that problem desc in this bug have been edited.
Comment 13 Michael Stahl (CIB) 2013-05-28 18:23:45 UTC
ok so this is

1. not a regression, already happens in earlier LO versions and OOo
2. a duplicate of bug 62601, which is about a different checkbox
   on the find & replace dialog but certainly has the same root cause

*** This bug has been marked as a duplicate of bug 62601 ***
Comment 14 Michael Stahl (CIB) 2013-05-28 18:25:15 UTC
reset mysteriously changed field