Bug Hunting Session
Bug 64664 - PDF: Rotated text corrupted when flattening transparent objects for PDF/A
Summary: PDF: Rotated text corrupted when flattening transparent objects for PDF/A
Status: RESOLVED DUPLICATE of bug 58173
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-16 08:50 UTC by Jim Avera
Modified: 2016-05-10 12:33 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
bug.odg -- draw doc showing the bug (11.51 KB, application/vnd.oasis.opendocument.graphics)
2013-05-16 08:50 UTC, Jim Avera
Details
Screen-shot showing what the "bug.odg" looks like in LO (83.41 KB, image/png)
2013-05-16 08:52 UTC, Jim Avera
Details
PDF/A pdf showing corrupted (mostly missing) text (190.56 KB, application/pdf)
2013-05-16 08:53 UTC, Jim Avera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2013-05-16 08:50:52 UTC
Created attachment 79388 [details]
bug.odg -- draw doc showing the bug

PDF/A does not allow transparency.  So when exporting to PDF with the PDF/A option selected, any transparent objects are converted to images (with a warning). 

However if there is rotated (e.g. vertical) text near by, the text gets corrupted in the resulting PDF -- most pixels are invisible.  Moving the text further away from the transparent objects makes the problem disappear, so I suspect there is a bug where the rotated bounding box is not used where it should be (or vice versa).  Or something like that.

STEPS TO REPRODUCE:
1. Load attached "bug.odt" drawing into LO
2. File->Export->PDF, select PDF/A option, and save.
3. View the resulting pdf with acroread -- the text is corrupted


Operating System: Ubuntu
Version: 4.0.3.3 release
Comment 1 Jim Avera 2013-05-16 08:52:30 UTC
Created attachment 79389 [details]
Screen-shot showing what the "bug.odg" looks like in LO
Comment 2 Jim Avera 2013-05-16 08:53:19 UTC
Created attachment 79390 [details]
PDF/A pdf showing corrupted (mostly missing) text
Comment 3 Joel Madero 2013-06-23 03:43:37 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.2.0.0.alpha0+Build ID: b0a1666f756aa5f5315366eca9d7d02ddd55d2b
Date:   Tue May 28 08:51:01 2013 +0300 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Minor - won't prevent high quality work but if a user ignores the warning about transparency and sticks with PDF/A despite having transparency, this bug may slow down their work as they'd have to re-export as regular PDF to get results they want. 
Low - seems like it really wouldn't impact many people - most people exporting pdf's are using regular pdf export not PDF/A - on top of this only affecting users using transparency and ignoring the warning about PDF/A and transparency not being friendly


Thanks for the report!

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 4 Jim Avera 2013-07-01 23:27:22 UTC
PDF/A is a variant of PDF designed for long-term archiving.  Unlike regular PDFs, PDF/A does not depend on external data to be rendered.  For example, it does not depend on certain fonts being pre-installed in your rendering mechanism (printer or software print driver).  A key requirement for archival documents is that they can be rendered in the future without relying on specific printers or software companies continuing to exist.

So "re-export as regular PDF" is not a solution for people creating documents to be archived for a long time.

I think there is no valid work-around.  It's not a terrible limitation to not support PDF/A (when certain embedded images are present), but it is a non-minor bug IMO.

Best,
-Jim
Comment 5 Jim Avera 2013-07-01 23:31:27 UTC
Following up, it would be helpful if the bug could be *detected* and the user warned of possible corruption, even if the bug is too hard to fix right now.

Currently the "archival" PDF is silently corrupted.  Certain bits just disappear.
Comment 6 Joel Madero 2013-07-02 05:19:23 UTC
You've sold me on it being a bigger deal than I first thought. 

Upping it to normal - high due to the silent corruption

Major - Corrupts data

Medium - while I agree with your assessment I still think it's affecting a low number of users so bumped it down from default of high.

Do you happen to know if this problem exists on 3.6?
Comment 7 Joel Madero 2013-07-02 05:20:29 UTC
I meant Major - Medium - my bad :)
Comment 8 Jim Avera 2013-07-05 18:09:58 UTC
> Do you happen to know if this problem exists on 3.6?

The bug is present in 3.5.7.2 (I don't have 3.6 installed).
Comment 9 QA Administrators 2015-04-01 14:43:03 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 10 Jim Avera 2015-04-11 17:44:16 UTC
Bug is still present in LibreOfficeDev 4.4.2.0.0

(the text is silently dropped from the PDF)
Comment 11 tommy27 2016-04-16 07:25:57 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 12 Heiko Tietze 2016-05-10 12:33:07 UTC
Closing this as duplicate of 58173 to keep the ticket list comprehensive.

*** This bug has been marked as a duplicate of bug 58173 ***