Download it now!
Bug 64676 - FILEOPEN: Opening MSO Excel XML files failing with «General Error. General input/output error.»
Summary: FILEOPEN: Opening MSO Excel XML files failing with «General Error. General i...
Status: RESOLVED DUPLICATE of bug 63756
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-05-16 15:50 UTC by Anton Derbenev
Modified: 2013-05-17 09:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example of Excel XML spreadsheed, which can't be opened with LO (11.80 KB, text/xml)
2013-05-16 15:50 UTC, Anton Derbenev
Details
another Excel XML file, which can't be opened with LO. (37.19 KB, text/xml)
2013-05-16 15:56 UTC, Anton Derbenev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Derbenev 2013-05-16 15:50:43 UTC
Created attachment 79433 [details]
Example of Excel XML spreadsheed, which can't be opened with LO

Problem description: 

Steps to reproduce:
1. Take one of attached files (I've got many of them)
2. Try to open it with LO (any way: file → Open, drag & drop, open with)
3. Get the error message (General Error.  General input/output error.)

Current behavior:
the error message (General Error.  General input/output error.)

Expected behavior:
file get opened as spreadsheet.

I'm not sure when it stopped working, but it definitely works in OOo 3.3.
             
Operating System: All
Version: 4.0.2.2 release
Last worked in: (See in Summary)
Comment 1 Anton Derbenev 2013-05-16 15:52:47 UTC
at #libreoffice, vilpan confirmed, that it opens well with LO 3.5.4.
Comment 2 Anton Derbenev 2013-05-16 15:56:32 UTC
Created attachment 79435 [details]
another Excel XML file, which can't be opened with LO.

I've got lots of them, please ask, if you'll need more.
Comment 3 retired 2013-05-16 16:21:41 UTC
Hi Anton,

I can't reproduce this problem on OS X 10.8.3 with LO 4.0.3.3. Both files open without any glitch for me.

Could you please

* install LO 4.0.3.3 and see if the bug persists
* if that is the case: which OS (and version) are you using?

Could you also please try resetting your user profile to make sure the issue is not related to that: 
https://wiki.documentfoundation.org/UserProfile#Resetting_the_user_profile

Thanks, James :)
Comment 4 Jorendc 2013-05-16 16:27:52 UTC
Hi,

Thanks for reporting.

I can not reproduce this using Mac OSX 10.8.3 with LibreOffice 4.0.3.3.

@Anton: what operation system did you use? You reported this bug against 'all'. Did you do that by purpose?

Kind regards,
Joren
Comment 5 Anton Derbenev 2013-05-16 20:06:53 UTC
updated to LO 4.0.3.3, problem intact. For me, Reproducible on 2 systems: one with windows 7 32bit, another with XP.
Will try clean profile tomorrow.

OS is clearly Windows, didn't test others.
Comment 6 Urmas 2013-05-17 04:31:31 UTC
1. What the hell "#VersionВерсия 1.22 от 24.03.10" does in XML content?
2. But that doesn't seem the actual problem.

*** This bug has been marked as a duplicate of bug 63756 ***
Comment 7 Anton Derbenev 2013-05-17 08:49:42 UTC
> Could you also please try resetting your user profile to make sure the issue
> is not related to that: 

Same with clean profile.
Comment 8 Anton Derbenev 2013-05-17 08:52:55 UTC
(In reply to comment #6)
> 1. What the hell "#VersionВерсия 1.22 от 24.03.10" does in XML content?

This document is formed by largest private commercial bank in Russia, Alfa-Bank. Not sure how they make it, with MS Office or some other software.
Comment 9 Jorendc 2013-05-17 09:57:01 UTC
(In reply to comment #6)
> 1. What the hell "#VersionВерсия 1.22 от 24.03.10" does in XML content?

I don't want to start a discussion in this bug report ... by "what the hell" is that for a question? What does the content matter? I think the only thing thats matter here is to help Anton and others with this behavior. So please save us timae with don't make this kind of non-sense comments.

Kind regards,
Joren