Download it now!
Bug 64718 - PDF: eps fig can not be exported to pdf file
Summary: PDF: eps fig can not be exported to pdf file
Status: RESOLVED DUPLICATE of bug 34836
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-17 14:57 UTC by qfeng.chen
Modified: 2013-05-17 18:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
You can try with the eps file attached. (90.87 KB, image/x-eps)
2013-05-17 14:57 UTC, qfeng.chen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description qfeng.chen 2013-05-17 14:57:54 UTC
Created attachment 79468 [details]
You can try with the eps file attached.

Problem description: 

When exporting pdf from drawing, the inserted eps file disappeared


Steps to reproduce:
1. start drawing
2. insert an eps file
3. select export to pdf and save the exported pdf file

Current behavior:
The content of the eps file disappeared.

Expected behavior:
The content of the eps file should be in the pdf file.
              
Operating System: Debian
Version: 4.0.2.2 release
Comment 1 qfeng.chen 2013-05-17 15:17:14 UTC
The eps file will disappear when you right click on the eps file and click Convert to Bitmap.
Comment 2 Julien Nabet 2013-05-17 18:45:43 UTC
On pc Debian x86-64 with master sources updated today, I reproduced the problem.

I noticed these logs:
- during eps insert in draw
warn:legacy.osl:17452:1:sal/osl/unx/file.cxx:352: FileHandle_Impl::readAt(): not seekable

during pdf export:
several of these
warn:sfx2.dialog:17452:1:sfx2/source/dialog/tabdlg.cxx:1137: CreateInputItemSet not implemented
warn:vcl.control:17452:1:vcl/source/control/button.cxx:2357: No new-style group set on radiobutton, using old-style digging around
Comment 3 Julien Nabet 2013-05-17 18:46:54 UTC
Thorsten: one for you? (since Impress and Draw are related)
Comment 4 Julien Nabet 2013-05-17 18:53:07 UTC
sorry Thorsten, I should have checked bugzilla, it isn't a new issue.

*** This bug has been marked as a duplicate of bug 34836 ***