Bug 64724 - EDITING When a Header/Footer is too high for the given space (dynamic space turned off..), it is not shown at all, without any warning / indication
Summary: EDITING When a Header/Footer is too high for the given space (dynamic space ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 43746 52325 (view as bug list)
Depends on:
Blocks: Calc-Header-Footer
  Show dependency treegraph
 
Reported: 2013-05-17 18:35 UTC by Todd
Modified: 2019-02-03 19:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Header is too big and doesn't show (11.92 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-05-17 18:35 UTC, Todd
Details
Screenshots with 3 heights showing how what fits is seen. (117.01 KB, image/png)
2013-05-18 00:32 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Todd 2013-05-17 18:35:16 UTC
Created attachment 79481 [details]
Header is too big and doesn't show

Hi All,

When a header is too large for the space, it doesn't show (does when imported into Excel).  The work around is to go into Format, Page, Headers (or footers), and click "Autofix Height".

Would you please come up with some indication of a problem?  Maybe show only what fits so the user knows something is wrong?  Or make "Autofix Height" to default?

I have attached a sample of the problem.  Load the file, then click on print preview to see (or not see) the missing header.

Many thanks,
-T
Comment 1 m.a.riosv 2013-05-17 21:19:07 UTC
Hi Todd,
I think the issue is you have only 0,1 cm for height, enable Autofix Height do their job.
You need at lest 0,6 cm for height to show the header.

Change status to RESOLVED NOTABUG, please if you are not agree REOPEN.
Comment 2 Cor Nouws 2013-05-17 21:50:41 UTC
@todd: thanks for reporting (again ;) )

made some clarification in the summary
and I will mark two other bugs as duplicate

@mariosv: sorry for stepping in (my comment basically crossed yours...)
Comment 3 Cor Nouws 2013-05-17 21:51:15 UTC
already an old issue
Comment 4 Cor Nouws 2013-05-17 21:52:16 UTC
*** Bug 43746 has been marked as a duplicate of this bug. ***
Comment 5 Cor Nouws 2013-05-17 21:52:43 UTC
*** Bug 52325 has been marked as a duplicate of this bug. ***
Comment 6 m.a.riosv 2013-05-18 00:32:55 UTC
Created attachment 79487 [details]
Screenshots with 3 heights showing how what fits is seen.

Sorry Todd and Cor,

maybe I am obfuscated, but I can not see what is the bug?.

Autofit Height works fine for me.

If I have set up a little height, I can see only what fits, increase the height a bit and it can be seen better.

So for me it is not a bug.
Comment 7 m.a.riosv 2013-05-18 00:39:04 UTC
I forgot my program and system data:
Win7x64 Ultimate
LibreOffice 3.3.4 OOO330m19 (Build:401) tag libreoffice-3.3.4.1
LibreOffice 3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
Version 4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539)
Comment 8 Todd 2013-05-18 00:48:43 UTC
(In reply to comment #6)
> Created attachment 79487 [details]
> Screenshots with 3 heights showing how what fits is seen.
> 
> Sorry Todd and Cor,
> 
> maybe I am obfuscated, but I can not see what is the bug?.
> 
> Autofit Height works fine for me.
> 
> If I have set up a little height, I can see only what fits, increase the
> height a bit and it can be seen better.
> 
> So for me it is not a bug.


Hi Mariosv,

Autofit works for me too.  Problem is that Autofit is off by default.  I know better, but your standard office worker won't have a clue that something is wrong, just that their header is there when they go into headers, but doesn't print or show in print preview -- no reason given.  You need to make things "intuitive" not geeky.  So what if there is a workaround if it is not intuitive to the user?

Call this an enhancement if you like, but please fix it.  I keep getting it reported to me, which is why I have reported it twice to you by accident.

Maybe put Autofit on by default?

Many thanks,
-T
Comment 9 m.a.riosv 2013-05-18 00:55:20 UTC
Hi Todd,
I can understand as a request for enhancement Autofit by default, even more I am agree, but then for me the right is change the importance from normal to enhancement.
Comment 10 Todd 2013-05-18 03:04:36 UTC
(In reply to comment #9)
> Hi Todd,
> I can understand as a request for enhancement Autofit by default, even more
> I am agree, but then for me the right is change the importance from normal
> to enhancement.

Works for me!  Thank you.
Comment 11 Cor Nouws 2013-05-20 06:07:15 UTC
(In reply to comment #9)

> I can understand as a request for enhancement Autofit by default, 

I can make a patch for that.
Do you think it would be needed to ask opinions at the UX-list before pushing the change?
Personally I think it's not a change that will lead to trouble .. ;)
Comment 12 m.a.riosv 2013-05-20 09:11:40 UTC
(In reply to comment #11)

> Do you think it would be needed to ask opinions at the UX-list before
> pushing the change?
> Personally I think it's not a change that will lead to trouble .. ;)

I think if it affects only new files, I am agree that can't lead to trouble.

But IMO better ask the UX-list, maybe with a short term to apply if nobody is against. This allow people know about it.
Comment 13 Cor Nouws 2013-06-18 14:14:55 UTC
(In reply to comment #11)

> Personally I think it's not a change that will lead to trouble .. ;)

I discussed this on IRC some time ago with a Calc developer and looked into the code. And it turns out complicated to change the option, since the setting is part of import filters of existing (als xls) documents.
So just changing the default, will lead to trouble..

So looks as if a proper warning, or pary showing is the right way to go here?
Comment 14 m.a.riosv 2013-06-18 19:45:42 UTC
Thanks Cor. Not seems the best to have a default option with such dependence on an import filter.

Is it not enough with change it in default template?