Download it now!
Bug 64770 - EDITING: Drawing Intersection Function Not Working Correctly
Summary: EDITING: Drawing Intersection Function Not Working Correctly
Status: RESOLVED DUPLICATE of bug 40259
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.6.0.0.alpha1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-19 20:23 UTC by Erik Martino
Modified: 2014-09-18 07:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example drawing (115.62 KB, application/vnd.oasis.opendocument.graphics)
2013-05-19 20:23 UTC, Erik Martino
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Martino 2013-05-19 20:23:16 UTC
Created attachment 79547 [details]
Example drawing

Problem description: 

Intersection between image and rectangle doesn't crop the image correctly but scales it to fit the rectangle.

Steps to reproduce:
1. Open the attached file
2. Select the top image and the transparent rectangle
3. Choose Shapes / Intersect

Current behavior:

The complete image is scaled with a skewed aspect to fit the rectangle

Expected behavior:

A cropped image of psy
Operating System: Ubuntu
Version: 4.0.2.2 release
Comment 1 Joel Madero 2013-05-20 16:43:12 UTC
Thank you for reporting this issue! I have been able to confirm the issue with the earliest version of bibisect:
Version 3.6.0.0.alpha1 
Platform: Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm this problem on an earlier release I am changing the version number as version is the earliest version that we can confirm the bug, we use comments to say that the bug exists in newer versions as well.

Marking as:

New (confirmed)
Minor - doesn't prevent high quality work, if you want to crop, there is another way to do so
Low - not used often (intersection) in general compared to a lot of other features


+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Cor Nouws 2013-05-24 11:47:53 UTC
( Hmm I added myself to Cc and all kind of fields are changed... WTF )
Comment 3 vvort 2014-09-18 07:31:55 UTC

*** This bug has been marked as a duplicate of bug 40259 ***