Bug Hunting Session
Bug 64842 - Accessibility - high-contrast inverse theme(s) (white FG, Black BG) not applied to documents.
Summary: Accessibility - high-contrast inverse theme(s) (white FG, Black BG) not appli...
Status: RESOLVED DUPLICATE of bug 71511
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-21 22:12 UTC by Zane
Modified: 2014-01-17 20:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Calc with black theme (High Contrast Inverse) on Ubuntu 13.04 (103.11 KB, image/png)
2013-05-21 22:12 UTC, Zane
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zane 2013-05-21 22:12:22 UTC
Created attachment 79632 [details]
Calc with black theme (High Contrast Inverse) on Ubuntu 13.04

Setting the system theme in Ubunut 13.04 to High-Contrast Inverse (white text on black background) does not reflect on the actual document being displaying. In Writer and Calc the document background is still white. This did not work this was in the past (granted, it has had its quirks). Given that many individuals require a high-contrast black style theme to do their work, it is important that the document reflect their system's settings when they choose a theme for accessibility reasons. I and a few others I know simply cannot use this version of LibreOffice due to this change. I also took a peek at Impress, but dont' really use it much so I personally cannot attest to how well it adapts. I can say that the background looked like it adapted, but many boundary lines could not be seen. Though I made the priority "normal," to those of us who need this functionality, it is extremely important.

I have added a screenshot of Calc as an attachment demonstrating this problem while using a black theme. I am not sure if this affects other distributions or OS at this time.

Thank you!
Comment 1 benoit.potvin 2013-06-10 18:00:27 UTC
I can confirm the bug on version 4.0.3.3 with Windows 7. I'm using High contrast black to recreate the bug.
Comment 2 Emilio Pozuelo Monfort 2013-07-31 08:47:08 UTC
This may be on purpose, see bug #35365
Comment 3 V Stuart Foote 2014-01-17 20:54:27 UTC
setting as duplicate of bug 71511 which has been verified fixed

Per Björn Michaelsen same issue with all OSs from a prior commit.

I tested in HC mode of RHEL 6.4/Centos 6.4 and found today's commit http://cgit.freedesktop.org/libreoffice/core/commit/?id=7f7a0275be241b8a5e1d1cda0a1da613e3af61d3 does restore use of the Linux DTE's HC settings when Tools -> Options -> Accessibility: Options for high contrast appearance are checked on.

*** This bug has been marked as a duplicate of bug 71511 ***