Download it now!
Bug 64847 - UI: Open various files in different Tabs in Writer
Summary: UI: Open various files in different Tabs in Writer
Status: RESOLVED DUPLICATE of bug 37134
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-22 05:16 UTC by goldfish
Modified: 2013-05-24 18:01 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description goldfish 2013-05-22 05:16:12 UTC
Problem description: No Tabs in LibreOffice window
Please can we have: Tabbed instances in LibreOffice like Firefox, (where there is increased productivity because of tabbed browsing in Firefox).

In other words please can we have a new feature that allows us to open various files in different Tabs in Writer?
For more details please see:
http://ask.libreoffice.org/en/question/17286/has-any-thoght-been-givin-to-tabbed-pages-in/?answer=17304#post-id-17304

Steps to reproduce:
1. No Tabs in LO window
2. ....
3. ....

Current behavior: No Tabs (unlike KingSoft Office)

Expected behavior: Want to increase productivity with Tabbed usage

              
Operating System: All
Version: unspecified
Comment 1 Jorendc 2013-05-22 17:19:41 UTC
Valid feature request. Therefore I mark it as such and set status to NEW.

Kind regards,
Joren
Comment 2 Owen Genat (retired) 2013-05-23 01:18:34 UTC
Joren, I am the author of the original answer on AskLO linked to in the description. I will leave it to you to decide whether or not this enhancement request is, in basic terms, a duplicate of bug #37134 (which is referenced in my AskLO answer). I feel that it likely is.

Reference in the description is made to the tabbed interface offered in KingSoft Office. While I am not familiar with this product, it would appear from the website that each component (Writer, Presentation, Spreadsheet, etc.) offers tabs on a per-document basis between the toolbar and the document area:

http://www.kingsoftstore.co.uk/windows/img/office-multiple-tabs.jpg
http://www.kingsoftstore.co.uk/img/writer-screen-big.jpg
http://www.kingsoftstore.co.uk/img/spreadsheets-screen.jpg
http://www.kingsoftstore.co.uk/img/presentation-screen.jpg

Unless the bug reporter can describe in more detail how this requested enhancement might differ from what bug #37134 is proposing, it would seem a duplicate to me.
Comment 3 rainer 2013-05-23 17:52:02 UTC
I simply want to show how it looks in Kingsoft's Writer under Ubuntu 12.04:

http://img841.imageshack.us/img841/3648/kingsoftwritertabs.png

The image shows three tabs: the "Online Templates" (web)page opened by default, and two documents. The screenshot also shows the "New tab" menu displayed (pointer hidden). Otherwise it works just like the "+" (New tab) button in Firefox or Opera.

Got Kingsoft's Office through the link provided here: http://www.omgubuntu.co.uk/2013/05/microsoft-office-clone-wps-updates-interface-improves

And, to me, this also looks as a duplicate of https://www.libreoffice.org/bugzilla/show_bug.cgi?id=37134
Comment 4 goldfish 2013-05-24 05:50:27 UTC
I feel the picture shared by rainer ( http://img841.imageshack.us/img841/3648/kingsoftwritertabs.png ) shows this so beautifully. As they say a picture is equal to 1000 words. Plus, his description makes it even more clear.

I do not think the pictures shared by Owen Genat explains tabbed usage as can be done with Opera & Firefox but these pictures make me think of the 'Ribbon'. I definitely will never request for the 'Ribbon' interface which many people dislike.

I also think this 'bug' feature request for an enhancement is a duplicate of “Bug" 37134. Therefore, suitable step to mark this as duplicate may be made & we can proceed accordingly.

Thanks everyone.
Comment 5 Adolfo Jayme 2013-05-24 18:01:05 UTC

*** This bug has been marked as a duplicate of bug 37134 ***