Bug 64849 - EDITING: Need Default Keyboard Shortcut for Strike-Through
Summary: EDITING: Need Default Keyboard Shortcut for Strike-Through
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2013-05-22 05:38 UTC by goldfish
Modified: 2019-04-25 12:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description goldfish 2013-05-22 05:38:19 UTC
Problem description: No default Keyboard Shortcut for Strike-Through like Ctrl + k

Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior: No default Keyboard Shortcut for Strike-Through

Expected behavior: Need default Keyboard Shortcut for Strike-Through like Ctrl + k

              
Operating System: All
Version: unspecified
Comment 1 Jorendc 2013-05-22 17:22:10 UTC
Valid feature request. Therefore I mark it as such and set status to NEW.

Kind regards,
Joren
Comment 2 Thomas Lendo 2019-01-14 23:37:04 UTC
Adding needsUXEval to discuss this.
Comment 3 Dave Barton 2019-04-23 10:26:43 UTC
I see no need to keep adding more and more defaults, users can easily customize keyboard shortcuts to suite their individual requirements.

IMPORTANT: If a strike-through default shortcut is to be defined, it should not be Ctrl+k which is already the default for Insert Hyperlink.
Comment 4 Ahiijny 2019-04-23 13:49:02 UTC
Ctrl + K is very commonly used in other places as an "insert hyperlink" shortcut, so I think that should be kept as it is.

Some other ideas:

Alt + Shift + 5
- used by Google Docs
- used by Google Sheets
- used by Google Slides
- used by Gmail

Ctrl + -
- used by OneNote

Ctrl + Shift + -
- used by Scrivener

Ctrl + 5
- used by Microsoft Excel

Ctrl + T
- used by Sticky Notes
- used by Lync

Ctrl + Shift + 6
- used by Tumblr
Comment 5 Thomas Lendo 2019-04-23 17:57:37 UTC
I've no preference, but it should be something with 5 or - (minus).
Comment 6 Cor Nouws 2019-04-24 12:49:06 UTC
Since many other editors have it, no problem to add this.
Since Ctrl+5 is Heading 5, I would chose Ctrl+-
Comment 7 Heiko Tietze 2019-04-25 10:37:35 UTC
(In reply to Cor Nouws from comment #6)
> Ctrl+-

That's occupied by the soft-hyphen.
Comment 8 Heiko Tietze 2019-04-25 12:57:33 UTC
We discussed the topic in the design meeting. While some apps provide shortcuts for this feature it's not the most frequently used. And we run low on free shortcuts anyway meaning the proposed ctrl+k and - are occupied. Changing the known shortcuts is a regression for many users. So the verdict is to use the customization instead of providing a factory setting.

(Ideally we have extensions to switch the shortcuts, there is a ticket somewhere containing the howto...)