Download it now!
Bug 64856 - UI: Navigation toolbar does not stick
Summary: UI: Navigation toolbar does not stick
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-05-22 09:30 UTC by Kumāra
Modified: 2013-08-30 03:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kumāra 2013-05-22 09:30:11 UTC
First of all, I need to clarify that I'm *not* referring to another element of the same name that is accessible in the Navigator pane, and at the bottom of the vertical scrollbar.

This Navigation toolbar is one among the many toolbars that can be placed above (with View > Toolbars > Navigation) and that is available only for Writer.

I notice that on this version (3.6.6.2), it refuses to stick. After causing it to be shown (and I can use it just fine), after closing and reopening LO, the toolbar disappears.

The toolbar almost would not appear when I open another window while having one that has the toolbar shown.
Comment 1 tommy27 2013-08-25 12:40:09 UTC
I do not reproduce it on LibO 4.0.4.2 under Win7 64bit.
If I activate that toolbar it stays there even if I close and reopen LibO.

please consider upgrading to the 4.0 branch (4.0.5 is out and 3.6 is end-of-life).
please indicate your platform (Linux, Windows or Mac)

P.S. removed "regression" from title and added it to keywords
Comment 2 Kumāra 2013-08-26 06:07:22 UTC
Thanks for the attention.

The issue remains in my LO 4.1.0.4 under Win7 64bit. I've found a workaround though: Add the 2 icons in a custom toolbar.
Comment 3 ign_christian 2013-08-26 07:17:59 UTC
I can reproduce on LO 4.0.5.1 (Win7 32bit). Navigation toolbar disappear/inactive after closing & reopening Writer.
Comment 4 Michael Stahl (CIB) 2013-08-29 15:38:23 UTC
this is a sub-bug of bug 60411 but this one
is actually a regression since it worked in LO 3.4.6
Comment 5 Michael Stahl (CIB) 2013-08-29 19:29:04 UTC
was introduced by:

commit c269a684f12c331a5d90a36e50a6275b072886f8
Author:     Tim Hardeck <thardeck@suse.com>
AuthorDate: Tue Nov 15 20:42:00 2011 +0100

    Hide Navigation toolbar until needed
    
    Hide Navigation toolbar until there is something to navigate.


... which actually appears to work: click on stuff in the
Navigator window and the toolbar appears.

so not a bug but a feature after all.
Comment 6 Kumāra 2013-08-30 03:11:19 UTC
Ohh.... :-p