Bug Hunting Session
Bug 64857 - FILESAVE: Column Width not remembered
Summary: FILESAVE: Column Width not remembered
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.6.2 release
Hardware: All All
: high minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks:
 
Reported: 2013-05-22 09:33 UTC by ign_christian
Modified: 2018-02-18 12:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test File (9.50 KB, application/vnd.ms-excel)
2013-05-22 09:33 UTC, ign_christian
Details
Affected XLS file example (12.00 KB, application/vnd.ms-excel)
2016-04-28 11:56 UTC, brucehohl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ign_christian 2013-05-22 09:33:44 UTC
Created attachment 79640 [details]
Test File

Column width information not remembered correctly on XLS.

Steps to reproduce:
1. Open attached file
2. Autofit width all columns A-F -> mark all columns A-F & double-click separator column F-G
3. Check that column width should be the same as written on row 27
4. Save, close, & reopen file
5. Check & see that column width change to what is written on row 28
6. Modify cell A1 by inputting single space, then enter
7. Save, close, & reopen file
8. Check & see that column width change to what is written on row 29

Problem: column width change unexpectedly without any changes that affect width

Tested on LO 4.0.3.3 (Win7 Home Premium 32bit). I believe this problem persists since LO 3.6.
Comment 1 ign_christian 2013-05-22 10:12:20 UTC
Tested on LO 3.6.6.2 (Ubuntu 12.04 32bit) generates same behavior with slightly different value (smaller column width)
Comment 2 Joel Madero 2013-05-24 16:11:16 UTC
I'm using inches but I do see that the #'s are definitely changing.

Bodhi Linux
LibreOffice Version 3.6.6.2

Marking as:
New
Minor - doesn't prevent high quality work but can slow it down substantially
High - in general these are low but I think column width is one of those things that most people expect to work correctly. Furthermore it's a feature that essentially anyone using spreadsheet depends on (ie. not some special feature)


Thanks for the clear report, really easy to triage this one due to attachment and steps :)
Comment 3 Joel Madero 2014-02-27 22:55:22 UTC
In order to limit the confusion between ProposedEasyHack and EasyHack and to make queries much easier we are changing ProposedEasyHack to NeedsDevEval.

Thank you and apologies for the noise
Comment 4 Robinson Tryon (qubit) 2015-12-13 11:21:01 UTC Comment hidden (obsolete)
Comment 5 brucehohl 2016-04-28 11:56:50 UTC Comment hidden (off-topic)
Comment 6 brucehohl 2016-04-28 11:59:30 UTC Comment hidden (off-topic)
Comment 7 Justin L 2016-12-26 16:38:44 UTC
I was completely unable to replicate.  Tested with bibisect43all back to last36onmaster.  (Ubuntu 16.04 x64).  F column width was always 1.12in.