Bug 64885 - EDITING: range name completion doesn't understand that names can contain underscores
Summary: EDITING: range name completion doesn't understand that names can contain unde...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.6.2 release
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks: Cell-Name
  Show dependency treegraph
 
Reported: 2013-05-23 00:00 UTC by scott
Modified: 2021-04-25 21:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description scott 2013-05-23 00:00:18 UTC
1. Name a cell 'foo1'
2. Name another cell 'my_favorite'
3. Start typing a formula:  =my_f

Range name autocompletion will suggest 'foo1' and choosing it results in 'my_foo1'

Instead, I expect 'my_favorite' to be suggested.
Comment 1 Francisco 2013-05-23 01:26:03 UTC
Scott:

I think there's something I'm missing. When I follow your steps, autocompletion suggest "=MAX(", because of the formula "MAX", but nothing with "foo1".

When I start to type "my" on a cell in Calc, it suggest "my_favourite" as the cell on step 2.
Comment 2 scott 2013-05-23 07:44:17 UTC
(In reply to comment #1)
> When I start to type "my" on a cell in Calc, it suggest "my_favourite" as
> the cell on step 2.

Yes, but the issue is that when you've typed 'my_f' the suggestion is 'foo1'; imagine the set of names is:

foo1
my_cat
...
my_favourite
my_food
...

Now when you type 'my_f' you want to be able to choose between my_favourite and my_food but what you get is 'foo1'

(In my actual spreadsheet I have 150+ names (not all with the same prefix, though).)
Comment 3 Joel Madero 2013-05-24 15:57:49 UTC
I'm able to confirm this on 3.6.6.2 release, updating version as version reflects oldest version that we see the issue - this is likely even older, maybe all the way back to beginning of LibreOffice days but I don't have the means to test that assumption right now.

Marking as:
New
Minor - doens't prevent high quality work, but can slow it down a little
Low - default seems appropriate, relatively easy to workaround this issue.

ProposedEasyHack
Comment 4 Joel Madero 2013-05-24 15:58:29 UTC
Sorry forgot to say:
Bodhi Linux x64
LibreOffice Version Tested: 4.0.3.3 release & 3.6.6.2 release
Comment 5 Joel Madero 2014-02-27 22:55:23 UTC
In order to limit the confusion between ProposedEasyHack and EasyHack and to make queries much easier we are changing ProposedEasyHack to NeedsDevEval.

Thank you and apologies for the noise
Comment 6 Robinson Tryon (qubit) 2015-12-13 11:21:01 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-01-03 19:49:46 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2019-12-03 14:10:10 UTC Comment hidden (obsolete)
Comment 9 Andreas Heinisch 2021-04-25 21:12:55 UTC
Cannot reproduce it in:
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 0e621eda01eb942bc46d32abc2f9e0e76ef16313
CPU threads: 6; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-US
Calc: CL

nor in:
Version: 6.4.7.2 (x64)
Build-ID: 639b8ac485750d5696d7590a72ef1b496725cfb5
CPU-Threads: 6; BS: Windows 10.0 Build 19042; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: CL