Download it now!
Bug 64902 - Add new menu options to move rows/columns in tables without overwriting the original cells
Summary: Add new menu options to move rows/columns in tables without overwriting the o...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: László Németh
URL:
Whiteboard: target:6.5.0 target:6.4.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-23 09:59 UTC by Paddy Landau
Modified: 2019-12-24 20:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paddy Landau 2013-05-23 09:59:31 UTC
This is virtually a duplicate of bug #35570, but it involves columns instead of rows within Writer tables.

The wording is the same, bar using "column" instead of "row".

Do this within Writer:

   1. Create a table of several rows and columns
   2. Enter content into all rows
   3. Highlight one complete column by click-and-dragging the mouse from the first column to the last
   4. Using the mouse, click on that column and drag it to another column

What happens: the contents of the column you want to move overwrite the contents of the column you move it to and leave a blank column where you moved it from.

What is expected: the column you move should be inserted at the location you drag it to, while all columns between the two locations should be moved left or right, depending on where you are moving from, so that all information is still intact, and no blank columns are left.

The reason for this bug is exactly the same as for bug #35570.
Comment 1 Cor Nouws 2013-05-23 10:44:48 UTC
Hi paddy,

thanks for reporting this.
I set this as duplicate and change the subject of 35570. I guess that changing the one, will result in changing the other to ;)
Regards,
Cor

*** This bug has been marked as a duplicate of bug 35570 ***
Comment 2 Paddy Landau 2013-05-23 10:51:45 UTC
Thank you, Cor. That makes sense.
Comment 3 László Németh 2019-12-16 20:17:01 UTC
I reopen this to file the new table popup menu items Paste Special->Table Row/Column and Edit->Paste Special->Paste Table Row/Column.
Comment 4 László Németh 2019-12-16 20:19:11 UTC
Note: Word 2016 uses a toolbar on its table popup menu to handle these and the function "paste as nested table".
Comment 5 Commit Notification 2019-12-17 10:51:14 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7efae60f3625a58f8a617c80f2a55a695fbaef36

tdf#64902 Writer table: Paste Special->Rows Above

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 László Németh 2019-12-17 11:54:32 UTC
tdf#64902 Writer table: Paste Special->Rows Above

and Columns Before table popup and Edit menu items
to insert clipboard table data in a table as new
rows/columns instead of overwriting the content of
the original cells of the target table.

This commit introduces the new commands
.uno:PasteRowsBefore and .uno:PasteColumnsBefore.

See also commit 1e278d1d0cfb1d5375195aa764739f00633f21e8
(tdf#37156 Writer menu: Paste as Nested table).
Comment 7 Commit Notification 2019-12-17 12:30:13 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/7809e80bc10293eca04a531e64e2f192d1a1d261

tdf#64902 Writer table: Paste Special->Rows Above

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Paddy Landau 2019-12-18 15:43:12 UTC
For me, drag-and-drop doesn't work, but cut-and-paste does.
Comment 9 Buovjaga 2019-12-20 21:06:27 UTC
(In reply to Paddy Landau from comment #8)
> For me, drag-and-drop doesn't work, but cut-and-paste does.

The drag-and-drop fixes to bug 35570 landed after your comment, on 2019-12-18 18:58:26 UTC. Please try with a master build that is fresher than this date.
Comment 10 Paddy Landau 2019-12-24 16:34:10 UTC
I confirm that the latest version works for me.
Thank you, everyone who contributed to this fix.