Bug 64990 - Importing PDF does not allow various page formats in one file
Summary: Importing PDF does not allow various page formats in one file
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 76637 78690 (view as bug list)
Depends on: 49787
Blocks: PDF-Import-Draw
  Show dependency treegraph
 
Reported: 2013-05-25 23:10 UTC by lennart.borgman
Modified: 2016-12-14 18:51 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
pdf with different page orientation (27.44 KB, application/pdf)
2014-08-07 15:52 UTC, Kevin Suo
Details
patch that chooses the largest dimensions for the page size (2.37 KB, patch)
2016-12-14 18:32 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lennart.borgman 2013-05-25 23:10:11 UTC
Problem description: Page format was set to page format for first page in the pdf file. The page format for the first page seems to be something like half the height of the rest of the pages (which are A4 I think). This resulted in hidden text. The lower half of the pages could not be viewed.

Steps to reproduce:
1. Open the pdf file

Current behavior: See above.

Expected behavior: Use the actual page format used in the pdf for each page. (Alternatively use the biggist page format found in the pdf file.)

Note: Unfortunately I can not attach the pdf since I do not have the right to distribute it.

              
Operating System: Windows 7
Version: 3.6.6.2 release
Comment 1 Cor Nouws 2013-05-26 10:33:58 UTC
Hi lennart,

thanks for your report!

(In reply to comment #0)

> Expected behavior: Use the actual page format used in the pdf for each page.
> (Alternatively use the biggist page format found in the pdf file.)

Since PDF files are imported in Draw, and Draw currenly does not support multiple page formats in one file.... I think we have a problem here...

> Note: Unfortunately I can not attach the pdf since I do not have the right
> to distribute it.

You could have made a simple dummy file ;)

Set this one to New, enhancement etc.
Will look for an issue with Draw for multiple page sizes
Comment 2 Cor Nouws 2013-05-26 10:36:41 UTC
yes, found the other bug.
Regards - Cor
Comment 3 vvort 2014-04-27 05:31:23 UTC
*** Bug 76637 has been marked as a duplicate of this bug. ***
Comment 4 Jorendc 2014-05-16 16:58:30 UTC
*** Bug 78690 has been marked as a duplicate of this bug. ***
Comment 5 Kevin Suo 2014-08-07 15:52:25 UTC
Created attachment 104236 [details]
pdf with different page orientation

The attached pdf has 1st page in portrait, while 2nd page landscape. When import in Draw, all pages are shown portrait.

This blocks pdf import, so I set the priority to HIGH enhancement.
Comment 6 Robinson Tryon (qubit) 2014-12-04 21:00:57 UTC
WORKAROUNDS:

1) Print the file as PostScript and then use ps2pdf
http://listarchives.documentfoundation.org/www/discuss/msg09845.html

2) Print the file in parts, and then stitch the PDFs together:
http://listarchives.documentfoundation.org/www/discuss/msg09844.html
Comment 7 Heiko Tietze 2016-05-10 09:36:51 UTC
Might be a duplicate of 92948
Comment 8 Justin L 2016-12-14 18:32:04 UTC
Created attachment 129646 [details]
patch that chooses the largest dimensions for the page size

I noticed that none of the imported text is invisible, it simply spills off the end of the page.  However, it is easy enough for the user to simply edit the paper size to make it big enough to fit everything, so it isn't very important for the program itself to select an awkward paper size.

Attached is a patch that does just that however.
Comment 9 Justin L 2016-12-14 18:51:07 UTC
Marking as WONTFIX since the user needs to do some tweaking regardless, and no information is lost. It seems better to me to leave the page size as a REAL paper size rather than some custom thing.  And since Draw simply can only handle one paper size anyway, it is impossible to import with both original paper sizes.

If others strongly disagree with this, then they can lobby for submitting the patch in comment 8.