Download it now!
Bug 65005 - : XSLT problem with nonUTF encoded xml
Summary: : XSLT problem with nonUTF encoded xml
Status: RESOLVED DUPLICATE of bug 63756
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta1
Hardware: Other Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-26 14:21 UTC by Lubos
Modified: 2013-05-27 14:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
zipped xsl filter and two xml files (1.33 KB, application/x-zip)
2013-05-26 14:21 UTC, Lubos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lubos 2013-05-26 14:21:37 UTC
Created attachment 79803 [details]
zipped xsl filter and two xml files

Importing XML using own XSLT filter fails, when imported XML is encoded  windows-1250 (Central European and Eastern European languages).

Steps to reproduce:
Download attachments and extract
Create new filter in Writer (Tools - XML Filter Settings, add own Filter name, Aplication LibreOffice Writer, add own Name of file type, File extension should be xml and in tab Transformation for XSLT for import select bug-transform.xsl from attachment)
Test XSLTS with xml-cp1250.xml and xml-utf.xml

The first one will fail with General input output error.
The second one will success with Writer showing written text "Test".

This xsl filter actually do not extract data from imported data, will always show the same text "Test". Its just simplified example, but the same apply for filters that try extract something.
xml-cp1250.xml is encoded in windows-1250
xml-utf.xml is encoded in UTF-8

I can reproduce this problem also in LibreOffice 4.0.3 on Windows 7
This problem is NOT present in LibreOffice 4.0.3 on Ubuntu 12.04
This problem is NOT present in LibreOffice 3.5.7.2 on Ubuntu 12.04 (from Ubuntu repository)
This problem is NOT present in OpenOffice 3.4.1 on Ubuntu 12.04 or Windows 7.
This problem is NOT present in Unofficial Developer Builds for Apache OpenOffice 4.0 Snapshot (revision 1484679) on Windows 7.
Operating System: Windows 7
Version: 4.1.0.0.beta1
Comment 1 Urmas 2013-05-27 12:50:09 UTC
Confirmed with master.
Comment 2 David Tardon 2013-05-27 14:42:19 UTC

*** This bug has been marked as a duplicate of bug 63756 ***