Download it now!
Bug 65014 - extra click needed to change search direction
Summary: extra click needed to change search direction
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Andrzej Hunt
URL:
Whiteboard: target:4.2.0 target:4.1.0.0.beta2
Keywords:
: 65552 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-05-26 20:00 UTC by almos
Modified: 2013-06-14 09:39 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description almos 2013-05-26 20:00:17 UTC
The find toolbar has two buttons with arrows next to the entry field, those can be used to step to the next occurrence in the given direction. Clicking a few times on one of them jumps the highlighted part as expected, however, the first click on the other one does seemingly nothing, because it just moves the cursor to the other end of the highlighted part. If one clicks on the two buttons in turns, the selection remains at the same position, and the cursor jumps between the two ends of the highlighted part.
Comment 1 Cor Nouws 2013-05-26 20:59:59 UTC
adding Joren as cc...
Comment 2 Jorendc 2013-05-26 21:31:33 UTC
Yups, confirmed.
Thanks for reporting and thanks for the ping Cor.

Will have a look. Maybe I can improve it. This is rather an enhancement request then a bug, so I mark it as such.
Comment 3 Andrzej Hunt 2013-05-27 18:24:10 UTC
Taken this on -- initial patch which fixes this is currently in gerrit.
Comment 4 Michael Stahl (CIB) 2013-06-04 13:53:53 UTC
looks fixed to me now :)
Comment 5 Commit Notification 2013-06-04 13:56:07 UTC
Andrzej J.R. Hunt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c73a65db14f8ee57e382a04b0d38a704c0308458

fdo#65014 Fix backwards/forwards search change of direction.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2013-06-04 14:04:09 UTC
Andrzej J.R. Hunt committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=660f54347433b05cb2d0ab081ddf6209aff47cd2&h=libreoffice-4-1

fdo#65014 Fix backwards/forwards search change of direction.


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 ign_christian 2013-06-14 09:39:25 UTC
*** Bug 65552 has been marked as a duplicate of this bug. ***