Bug Hunting Session
Bug 65020 - EDITING: No response when Redo/Undo by pressing Ctrl+Z/Ctrl+Y very fast
Summary: EDITING: No response when Redo/Undo by pressing Ctrl+Z/Ctrl+Y very fast
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-27 03:38 UTC by johnteee
Modified: 2013-06-25 04:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description johnteee 2013-05-27 03:38:29 UTC
Problem description:
 
Hi,I found some problem when Redo/Undo in Writer...
It seems a little crashy when frequently pressing Undo...
When pressing Undo fast and many times,
it causes Writer no response and infinite Loop waiting
Maybe there're some bugs in Redo/Undo Command Pattern or something else concerning...
I uses Win7 32bits version,Libreoffice 4.0.3

Steps to reproduce:
1. Key in Many texts in many steps
2. Pressing Undo/Redo(by Ctrl + Z and Ctrl + Y) very fast,again and again(about ten times or above)

Current behavior:
It causes infinite waiting and Writer no response forever

Expected behavior:
It might make finite waiting and make response no matter how soon Ctrl+Z pressed.
              
Operating System: Windows 7
Version: 4.0.3.3 release
Comment 1 Ken Biondi 2013-06-25 04:03:08 UTC
I was not able to recreate this bug.  Created a text document and then pressed ctrl+Y and ctrl+Z many times with no problems.  I'm changing the status to resolved-works for me.  If this is still a problem for you, change the status back to unconfirmed and provide more information if possible.

Tested using:

LO Version 4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539)
WIN 8 x86_64