Bug Hunting Session
Bug 65021 - Table context menu keyboard accelerator "C" duplicated too many times
Summary: Table context menu keyboard accelerator "C" duplicated too many times
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2013-05-27 03:41 UTC by V Stuart Foote
Modified: 2017-08-01 12:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Table context menu showing duplicate accelerators (44.95 KB, image/jpeg)
2013-05-27 03:41 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2013-05-27 03:41:00 UTC
Created attachment 79826 [details]
Table context menu showing duplicate accelerators

See attached screen capture--there are conflicting keyboard accelerators on the context menu of the Table objects. Specifically the Change Case -> Capitalize Every Word is conflicting with using accelerator for Cell and for Caption.

Either the Capitalize Every Word "C" accelerator must be changed, or the Cell and Caption use of that accelerator must be.

Admittedly entering Shift+<F10> + C + C to capitalize contents of selected table cell is probably the best use of the accelerators. But Cell and Caption (i.e. Table title caption) do need to function with keyboard only input. Needs to be adjusted.
Comment 1 V Stuart Foote 2013-05-27 03:42:44 UTC
Sorry marking this confirmed as it is pretty obvious and repeatable on versions from 4.0.3 final through 4.2.0 alpha master.
Comment 2 V Stuart Foote 2013-05-27 03:56:05 UTC
Steps to reproduce:

1. Open new Writer document

2. <Alt>+a and i, or <CTL>+<F12> to create new table

3. position cursor in any of the Table cells so Table has focus, observable in that the Table menu opens

4. open Table context menu, <Shift>+<F10>

5. attempt to use keyboard to add Table caption:
expected
enter C -> move Change case
enter C -> move Cell
enter C -> move Caption and launch Insert Caption dialog panel

actual
enter C -> move Change case
enter C -> moves to and performs Capitalize Every Word
exits context menu

Accelerators need to be adjusted.
Comment 3 V Stuart Foote 2013-07-11 15:20:08 UTC
moving from writer to ux-advise

while this is a specific example, should be some systematic method of tracking accelerator assignments and avoiding reuse on a given menu when it causes functional issues/traps.
Comment 4 Mark Bourne 2015-04-11 12:02:08 UTC
(In reply to V Stuart Foote from comment #2)
> 5. attempt to use keyboard to add Table caption:
> expected
> enter C -> move Change case
> enter C -> move Cell
> enter C -> move Caption and launch Insert Caption dialog panel
> 
> actual
> enter C -> move Change case
> enter C -> moves to and performs Capitalize Every Word
> exits context menu
> 
> Accelerators need to be adjusted.

I was going to suggest this can be worked around by pressing left-arrow to close the sub-menus which open, but there's still a problem...
- press Shift+F10 to open Table context menu
- press "C"; Change Case menu opens
- press left arrow; Change Case menu closes
- press "C"; Cell menu opens
- press left arrow; Cell menu closes
- press "C"; Change Case menu opens, instead of highlighting Caption

So you're stuck with using up/down arrows to highlight Caption, and then press Enter.

Perhaps this should work similarly to the menu bar when there are conflicting accelerators, where pressing the letter highlights each menu item in turn without opening/activating it, and pressing Enter opens/activates the highlighted item.
Comment 5 Robinson Tryon (qubit) 2016-08-25 05:38:56 UTC Comment hidden (obsolete)
Comment 6 Heiko Tietze 2017-08-01 12:22:46 UTC
The context menu(s) have been reworked and the issue is solved in 6.0.