Bug 65065 - UI: ToC Preview Vanishes from UI
Summary: UI: ToC Preview Vanishes from UI
Status: RESOLVED DUPLICATE of bug 64287
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 Beta0
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-28 06:45 UTC by findjammer
Modified: 2013-05-28 08:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A screenshot showing an empty preview pane. (192.60 KB, image/png)
2013-05-28 06:45 UTC, findjammer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description findjammer 2013-05-28 06:45:27 UTC
Created attachment 79883 [details]
A screenshot showing an empty preview pane.

Problem description: 

When creating or updating a table of contents the preview is sometimes very out of line with the existing ToC and if you disable and then re-enable the preview it is not redrawn in the UI.

Steps to reproduce:
1. Create a basic document
2. Add a Table of Contents
3. Edit Table of Contents
4. Toggle the Preview checkbox

Current behavior:

ToC preview vanishes and only a close and reopen of the dialog repaints the preview,  sometimes the preview is not correct.

Expected behavior:

he preview toggle should repaint the ToC accurately every time
Operating System: Mac OS X
Version: 4.0.3.3 release
Comment 1 Cor Nouws 2013-05-28 08:00:36 UTC
Have seen this before 
is not correct in 3.5.0 beta
is correct in 3.4.0
so somewhere in between there it went wrong...
Comment 2 Cor Nouws 2013-05-28 08:00:59 UTC
ps: thanks for the report!
Comment 3 findjammer 2013-05-28 08:03:20 UTC
No problem.  Am loving LibreOffice!
Comment 4 Andras Timar 2013-05-28 08:53:05 UTC

*** This bug has been marked as a duplicate of bug 64287 ***