Bug Hunting Session
Bug 65113 - FORMATTING: Data displayed in wrong column, compared to MS Office
Summary: FORMATTING: Data displayed in wrong column, compared to MS Office
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA interoperability
Keywords: filter:pptx
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2013-05-29 06:51 UTC by Mirko Stocker
Modified: 2018-09-24 20:06 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
presentation that shows the problem (59.88 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2013-05-29 06:52 UTC, Mirko Stocker
Details
Chart Data Table (104.08 KB, image/png)
2013-05-30 03:04 UTC, ign_christian
Details
this is how the file looks in MS Office (162.86 KB, image/png)
2013-05-30 06:26 UTC, Mirko Stocker
Details
Information_Presentation_English_March_2013.pptx - LO 6.2 a0 (30.75 KB, image/png)
2018-09-24 20:05 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mirko Stocker 2013-05-29 06:51:00 UTC
Problem description: 

The chart shows some of the data points in the wrong column, when compared to MS Office.

Steps to reproduce:
1. Open the attached document

Current behavior:
The data points for "Master of Science in Engineering" and "Renewable Energies and Environmental Engineering" are shown in the years 2000-2004.

Expected behavior:
They should be shown in the years 2008-2012, at least this is was MS Office does. Unfortunately, I don't know how the chart was created.


              
Operating System: Linux (Other)
Version: 4.0.3.3 release
Comment 1 Mirko Stocker 2013-05-29 06:52:06 UTC
Created attachment 79934 [details]
presentation that shows the problem
Comment 2 ign_christian 2013-05-30 03:04:09 UTC
Created attachment 80010 [details]
Chart Data Table

Using LO 4.0.3.3 (Win7 32bit), it can be seen that chart match with the Data Table.

Could you compare it with chart data table on MSO & attach that screenshot?
Comment 3 Mirko Stocker 2013-05-30 06:26:35 UTC
Created attachment 80013 [details]
this is how the file looks in MS Office
Comment 4 Jorendc 2013-05-30 10:51:46 UTC
I can confirm this behavior using Mac OSX 10.8.3, with PowerPoint for Mac 2011 and LibreOffice 4.0.3.3.

Kind regards,
Joren
Comment 5 Cor Nouws 2013-06-10 12:58:57 UTC
thanks for the clear description and examples!

(In reply to comment #3)
> Created attachment 80013 [details]
> this is how the file looks in MS Office

testing in LibreOffice 4.1.0beta2 and 4.0.3.3 on Ubuntu it looks the same as in this screen print.
So I cannot reproduce the bug ...
Comment 6 Jorendc 2013-06-10 13:13:36 UTC
(In reply to comment #5)
> testing in LibreOffice 4.1.0beta2 and 4.0.3.3 on Ubuntu it looks the same as
> in this screen print.
> So I cannot reproduce the bug ...

Hi Cor :-)! I confirmed this bug using Mac OSX 10.8.3 (see Comment 4) and this bug is reported against Ubuntu, so I think platform 'all' is the proper one for this bug?

Still reproducible using Mac OSX 10.8.3 with LibreOffice Version: 4.1.0.0.beta2 
Build ID: 33224f4f11a05cfad2249e812fcc2975fbb61f6

Kind regards,
Joren
Comment 7 Cor Nouws 2013-06-10 13:26:01 UTC
(In reply to comment #6)

> Hi Cor :-)! I confirmed this bug using Mac OSX 10.8.3 (see Comment 4) and
> this bug is reported against Ubuntu, so I think platform 'all' is the proper
> one for this bug?

Yes I noticed you could reproduce!
Therefore I tripple checked ( :) ) the result against the screen shot provided for MS, before I dared to report ;)

Can the people with the bug test what happens when they acc some data in the last (but one) column for e.g. the past month?
Or when they just activate / refresh the chart?
Comment 8 Alexandr 2014-07-21 17:23:57 UTC
I reproduce the bug with LibreOffice 4.2.5 and 4.3.0 on Debian. 

> Can the people with the bug test what happens when they acc some data in the
> last (but one) column for e.g. the past month?
> Or when they just activate / refresh the chart?

Activation does not change the chart. If I add something to the table, the chart shows the changing, but the table (and, correspondingly, the chart) is still incorrect.
Comment 9 QA Administrators 2015-09-04 02:49:59 UTC Comment hidden (obsolete)
Comment 10 Alexandr 2015-09-19 17:57:12 UTC
Reproducible with LibreOffice 5.0.1 on Debian.
Comment 11 Robinson Tryon (qubit) 2015-12-07 16:35:09 UTC Comment hidden (obsolete)
Comment 12 QA Administrators 2017-01-03 19:43:23 UTC Comment hidden (obsolete)
Comment 13 Roman Kuznetsov 2018-09-24 20:05:41 UTC
Created attachment 145144 [details]
Information_Presentation_English_March_2013.pptx - LO 6.2 a0

Looks same as in MSO in

Version: 6.2.0.0.alpha0+
Build ID: 1aa37aa6bee19099b57555a6d839992b054aa405
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-09-23_10:17:54
Locale: ru-RU (ru_RU); Calc: threaded

Status -> WFM