Download it now!
Bug 65158 - Add an option "do not modify formulas" in the data>sort dialog
Summary: Add an option "do not modify formulas" in the data>sort dialog
Status: RESOLVED DUPLICATE of bug 81309
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-30 06:25 UTC by stragu
Modified: 2014-10-29 02:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stragu 2013-05-30 06:25:32 UTC
Problem description: 

At the moment, there is no option to sort cells depending on the results of formulas without breaking the formulas as the cells get reorganised.

Steps to reproduce:
1. Write several formulas which result depend on values contained in other cells throughout the sheet
2. Try to reorganise the cells thanks to the data>sort dialog

Current behavior:
Cells are reorganised but loose their value as formulas now refer to different cells.

Expected behavior:
There should be an option to conserve the formulas when sorting data.

              
Operating System: Ubuntu
Version: 4.0.3.3 release
Comment 1 Jorendc 2013-05-30 12:28:27 UTC
I can confirm this is a valid request. Thanks for reporting!

Tested so far:

* Open Calc
* enter:
A1 : 1
A2: 2
...
A5: 5

* create a formula in B1: =A1
* create a formula in B2: =$A$1
* Data > Sort
* sort 'Column A', Descending

Result: both B1 and B2 shows value 5.

Kind regards,
Joren
Comment 2 Kohei Yoshida 2014-07-18 01:24:16 UTC
Bug 81309 should address this problem.

*** This bug has been marked as a duplicate of bug 81309 ***
Comment 3 stragu 2014-07-18 08:30:43 UTC
Great, thanks Kohei!
Comment 4 stephanie park 2014-10-29 02:56:56 UTC
How about 4.3? 4.4 wasn't even working on Windows for the past month and as of Version: 4.3.2.2, Calc is still corrupting users spreadsheets.