Download it now!
Bug 65164 - FORMATTING: Cell borders: double lines are displayed wrong
Summary: FORMATTING: Cell borders: double lines are displayed wrong
Status: RESOLVED DUPLICATE of bug 57345
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2013-05-30 08:13 UTC by richard
Modified: 2015-12-17 10:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
cell format page (217.54 KB, image/png)
2013-05-30 09:52 UTC, richard
Details
cell at 400% magnification (231.64 KB, image/png)
2013-05-30 09:53 UTC, richard
Details
screen shot of all double lines (166.53 KB, image/jpeg)
2013-05-30 15:59 UTC, Kevin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description richard 2013-05-30 08:13:55 UTC
Problem description: 
Cannot set double line border


Steps to reproduce:
1. Select cell format
2. Set double line cell border (bottom)
3. ....

Current behavior:
Thick single line - even on zoom

Expected behavior:
Double line expected.

              
Operating System: Windows 7
Version: 4.0.3.3 release
Comment 1 Cor Nouws 2013-05-30 09:05:05 UTC
Hi Richard,

Thanks for the report, but it just works fine for me...
Have you tried to get support for users?
  http://www.libreoffice.org/get-help/
I never have real problems setting the borders, but it's not always straigt forward.
If you really find a bug, then pls :
 - attach a screen shot
 - preciese step by step procedure
 - and the test file.

thanks again & regards
Cor
Comment 2 richard 2013-05-30 09:52:34 UTC
Created attachment 80024 [details]
cell format page
Comment 3 richard 2013-05-30 09:53:21 UTC
Created attachment 80025 [details]
cell at 400% magnification
Comment 4 richard 2013-05-30 09:53:30 UTC
It happens with a new spreadsheet; I'm enclosing a couple of pngs; one of the cell format page, and one of the resulting cell format .. at a SERIOUS magnification. You can see that it's not a double line, but a large single one.
Comment 5 Cor Nouws 2013-05-30 10:44:54 UTC
I see a double line with the width set at
 - 0.05
 - 1.05
 - 2.55

but only with the really wider ones, it somehow looks stable/pretty.

I guess there's just or also the problem with screen resolution ?
How does it look on paper (don't have a printer here) ?
Does it show different in older versions that you know?
Comment 6 richard 2013-05-30 11:13:51 UTC
Screen resolution is 1920 x 1080 so that's not a problem (it's a HDMI 3D screen!).
AFA printing is concerned, 0.05 prints as a single thick line, whilst 2.55 just about shows some separation .. although it *looks* like a thin upper and thick lower (ie, the wrong version of the line selected).

Can't say about earlier versions .. although I don't recall having the same issue this time last year when I was going through the same exercise (producing a booklet for an annual meeting and formatting the accounts section).  The pdf I produced from the built-in last year shows fine double lines, whereas this year, the equivalent pages display either a thick single line or a very coarse, just about double line - so all things being equal, something has been changed that's caused the effect.  Unfortunately the most I can say about the version of LibreOffice I used to produce last years version is that it was 3.5 (from the pdf's properties) .. but as to which exact version ... don't know.  It was produced on 7th June last year, and as I keep the version of LO up to date, there's a good chance that it was the release version around then.
Comment 7 Kevin 2013-05-30 15:59:50 UTC
Created attachment 80050 [details]
screen shot of all double lines

I also can reproduce this. Also I have went a step further with mine. It's not just the identical double lines that are having issues but it appears all the double lines are having problems as shown by my attachment. Identical doubles show up as Bold Top Double. The Bold Top Double shows up as just a Single. The Bold Bottom Double just shows up as 1 Single Bold. 

These are all the defaults of .05 width and 1.0 height.
Comment 8 richard 2013-05-30 16:40:27 UTC
Yup - that look the same.

I've gone back to a VM I have that has 3.5 installed and that version works as I'd expect. I've taken a snapshot of the VM and upgraded LO to 3.6, and I can also now confirm that the same problem exists in 3.6 - and it's noticeable that the order of the available borders has changed between 3.5 and 3.6/4.0
Comment 9 Cor Nouws 2013-05-30 16:48:16 UTC
@michael
Since you did some (tons) of good work on this in the past.. any idea?
(Or was that mostly / solely Writer tables...)
thanks a million!
Comment 10 Cor Nouws 2013-05-30 16:49:02 UTC
OK Richard & Kevin,
thanks for all the testing and convincing information!
Comment 11 Cor Nouws 2013-05-30 16:55:47 UTC
as per comment #8 it's clear that the problem is somewhere in between 3.5 and 3.6.

(And since it's there for a year or so, I doubt if Major is justified...)
Comment 12 ign_christian 2013-07-13 03:08:01 UTC
Too many bugs concerning this, I wish that I'm not making a mistake while marking this as a duplicate. Or perhaps duplicate to another that linked to Bug 57345.

*** This bug has been marked as a duplicate of bug 57345 ***
Comment 13 my_wong 2013-09-24 05:04:20 UTC
I also have problems with double line borders using LO 4.1.1.2 Win 7

Doubles borders in xls files created by Excel 2010 are converted to 
single lines. Whereas in xlsx files, they are not converted at all.

Double borders created by LO saved as xls or xlsx also behave 
the same way. However the double borders appear fine in Excel
except double lines of different thickness (such as thick top thin 
bottom or vice versa) appear as two thin lines.
Comment 14 Robinson Tryon (qubit) 2015-12-17 10:38:08 UTC
Migrating Whiteboard tags to Keywords: (Bibisectrequest)
[NinjaEdit]