Download it now!
Bug 65168 - EDITING: Report-Builder: Wizard works only with old report-engine
Summary: EDITING: Report-Builder: Wizard works only with old report-engine
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta1
Hardware: Other Linux (All)
: high blocker
Assignee: Stephan Bergmann
URL:
Whiteboard: target:4.2.0 target:4.1.0.1
Keywords: regression
Depends on:
Blocks: mab4.1 61725
  Show dependency treegraph
 
Reported: 2013-05-30 09:40 UTC by Robert Großkopf
Modified: 2013-06-24 09:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of legacy report wizard (71.12 KB, image/png)
2013-06-06 14:30 UTC, Lionel Elie Mamane
Details
screenshot of reportbuilder wizard (78.51 KB, image/png)
2013-06-06 14:31 UTC, Lionel Elie Mamane
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2013-05-30 09:40:22 UTC
LO 4.1.0.0 beta1 an Linux 32bit rpm
Open a database.
Try to edit a report.
Manual editing of a report with the Report-Builder starts.
When you chose the wizard only the old report-engine starts. 

Expected behavior: 
You could chose between two wizards, one for the old engine and one for the Report-Builder.
Comment 1 Lionel Elie Mamane 2013-05-31 12:56:32 UTC
(In reply to comment #0)

> Expected behavior: 
> You could chose between two wizards, one for the old engine and one for the
> Report-Builder.

That would be nice, but has never been so. Previous versions just made the "old engine wizard" unavailable (as well as creating an "old engine" report from scratch in design mode).

OTOH, now that Report builder is not an extension anymore, is it still an *optional* install? If not, people that prefer it will scream the walls down :-( David? If it is not an optional install, could you make it so (make it installed by default, that is good). "Later" (when we get a volunteer) we can make it so that people can mix and match (that is, report builder *adds* possibilities instead of *replacing* them).


If now the wizard creates an old engine report, that's a regression.

Guesses about reasons:


commit 90a326c7028d5af132c62edfaef77c53627e4c0e
Author: David Ostrovsky <david@ostrovsky.org>
Date:   Wed Mar 13 22:45:02 2013 +0100

    fdo#61950 move report builder from bundled extensions to plain code


commit 6f28efc2a8a559cc8c37aa883f4de0b59d4fc79c
Author: David Ostrovsky <david@ostrovsky.org>
Date:   Thu Mar 7 08:17:56 2013 +0100

    fdo#61726: rename report-builder package to org.libreoffice.report
    


David? If you pick this up, and find it easier to just make Report builder *add* options "new reportbuilder report in design mode" and "new reportbuilder report by wizard" instead of *replacing* the existing "new report in design mode" and "new report in wizard", then by all means do so.

We could also rename the "old" "new report" stuff as "new *legacy* report" and reserve the "new report" for reportbuilder.
Comment 2 DavidO 2013-05-31 14:27:57 UTC
(In reply to comment #1)
> (In reply to comment #0)
> 
> > Expected behavior: 
> > You could chose between two wizards, one for the old engine and one for the
> > Report-Builder.
> 
> That would be nice, but has never been so. Previous versions just made the
> "old engine wizard" unavailable (as well as creating an "old engine" report
> from scratch in design mode).
> 
> OTOH, now that Report builder is not an extension anymore, is it still an
> *optional* install? If not, people that prefer it will scream the walls down
> :-( David? If it is not an optional install, could you make it so (make it
> installed by default, that is good). "Later" (when we get a volunteer) we
> can make it so that people can mix and match (that is, report builder *adds*
> possibilities instead of *replacing* them).
> 
i don't follow, completely lost you ;-)
I don't know anything about LO installation process, packages, Debian, Ubuntu.
I only use LO compiled from source.

And to be frankly i don't understand the problem. Please explain exactly what the problem is (if at all) and how to rectify it.

Note: Stephan switched other extension to be internal module.
Comment 3 Lionel Elie Mamane 2013-06-05 16:36:37 UTC
Setting as blocker since it is "unusable function" regression.

(In reply to comment #2)
> (In reply to comment #1)

>> Previous versions just made the
>> "old engine wizard" unavailable (as well as creating an "old engine" report
>> from scratch in design mode).

>> OTOH, now that Report builder is not an extension anymore, is it still an
>> *optional* install? If not, people that prefer it will scream the walls down
>> :-( David? If it is not an optional install, could you make it so (make it
>> installed by default, that is good). "Later" (when we get a volunteer) we
>> can make it so that people can mix and match (that is, report builder *adds*
>> possibilities instead of *replacing* them).

> I don't follow, completely lost you ;-)

LibreOffice has *two* report engines for Base. The "legacy" report engine and the "new" report builder. The report builder used to be an extension, and thus one could choose to install it or not. The choice not to install it was important because the mere installation of report builder made the legacy report engine unavailable: no way anymore to create a new legacy report from scratch or by wizard.

So, in Base of LibreOffice 4.0 and earlier, after one clicks on "Reports" in the left pane:

Report builder not installed:
 - upper right pane "create report in design view" creates a new blank legacy report
 - upper right pane "use wizard to create report" creates a new legacy report

Report builder installed:
 - upper right pane "create report in design view" creates a new blank reportbuilder report
 - upper right pane "use wizard to create report" creates a new legacy reportbuilder report


PROBLEM 1


With LibreOffice 4.1.0.beta:

Report builder installed:
 - Upper right pane "use wizard to create report" creates a new *legacy* report
   This is a regression, and makes creation of reportbuilder report by wizard UNAVAILABLE.


PROBLEM 2

*IF* report builder is not an OPTIONAL component, it is now impossible to get into state "Report builder not installed", and thus (after PROBLEM 1 is fixed) *impossible* to create legacy report! This is a regression.

PROBLEM 3

Having report builder merely installed should not make legacy report creation unavailable, it should give *new* choices (*new* entries in the upper right pane, not change behaviour of existing ones). This is *not* a regression, but fixing this will make problems 1 and 2 go away.
Comment 4 Lionel Elie Mamane 2013-06-06 14:30:31 UTC
Created attachment 80411 [details]
screenshot of legacy report wizard
Comment 5 Lionel Elie Mamane 2013-06-06 14:31:21 UTC
Created attachment 80414 [details]
screenshot of reportbuilder wizard
Comment 6 Lionel Elie Mamane 2013-06-06 14:35:16 UTC
How to reproduce for people that don't know anything about Base:

0) Use a LibreOffice with Report Builder installed.
   (Up to 4.0: bundled extension
    Since 4.1: optional installable component)

1) Open any .odb file

2) Click on Reports in left pane

3) In upper right pane, click on "use wizard to create report".

Expected behaviour: it should look like attachment 80414 [details] (it opens a report builder window in design mode)

Actual behaviour: it looks like attachment 80411 [details] (it opens a Writer window)
Comment 7 Lionel Elie Mamane 2013-06-06 14:37:19 UTC
*AND* (I was forgetting)


0) Use a LibreOffice WITHOUT Report Builder installed.
   (Up to 4.0: bundled extension
    Since 4.1: optional installable component)

1) Open any .odb file

2) Click on Reports in left pane

3) In upper right pane, click on "use wizard to create report".

Actual behaviour: it works, and it looks like attachment 80411 [details] (it opens a Writer window, and does changes in it when one clicks "next")
Comment 8 Stephan Bergmann 2013-06-06 15:48:29 UTC
Looks like startReportWizard in wizards/com/sun/star/wizards/report/ReportWizard.java still expects reportbuilderwizard.jar to be found in an extension (while it appears to be no longer installed at all).  Will take care of that.
Comment 9 Commit Notification 2013-06-07 10:17:08 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e57eeb6d5f547a4a49df796641141c733f6c5204

fdo#65168: Fix regressions introduced with de-extension-ing report builder



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2013-06-07 11:49:31 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0cd10346f94430128beee0b4084b27837ccda6fa&h=libreoffice-4-1

fdo#65168: Fix regressions introduced with de-extension-ing report builder


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Stephan Bergmann 2013-06-07 12:49:14 UTC
I verified that in a normal (per default --enable-report-builder) build "use wizard to create report" brings up the new dialog like in attachment 80414 [details] again.  I didn't explore any further, for lack of knowledge, but that might be advisable, in light of bug 61950 comment 11.
Comment 12 Commit Notification 2013-06-10 09:22:58 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5d4c41587dde658c9bfcb1638e0373608163bec2

fdo#65168: Fix previous fix, Class-Path is built up in solenv/gbuild/Jar.mk



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2013-06-10 10:07:06 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=80a7b52ba4903d4112ea8edef57f082756221d56&h=libreoffice-4-1

fdo#65168: Fix previous fix, Class-Path is built up in solenv/gbuild/Jar.mk


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 frofa 2013-06-24 09:38:48 UTC
"...PROBLEM 3: Having report builder merely installed should not make legacy report creation unavailable, it should give *new* choices (*new* entries in the upper right pane, not change behaviour of existing ones). This is *not* a regression, but fixing this will make problems 1 and 2 go away...."

As Lionel recommended (above), devs PLEASE don't remove access to the legacy Report Wizard. I use it quite often because it provides some options that do NOT seem to be available with the (now) integrated Report Builder - such as 'multi-column' layouts (e.g. repeated field sets) which are very useful for compact reports. I suspect others will also complain if access to this legacy tool is 'cutoff'.