Bug Hunting Session
Bug 65169 - Can't remove extra space from formula
Summary: Can't remove extra space from formula
Status: RESOLVED DUPLICATE of bug 65067
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-30 09:48 UTC by Ruslan Kabatsayev
Modified: 2013-11-21 15:59 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Test document (11.84 KB, application/vnd.oasis.opendocument.text)
2013-05-30 09:48 UTC, Ruslan Kabatsayev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ruslan Kabatsayev 2013-05-30 09:48:16 UTC
Created attachment 80023 [details]
Test document

Suppose I need to write a formula immediately followed by some text, e.g. "๐›ฟ-ั„ัƒะฝะบั†ะธั". I make a formula %delta, which is then followed by "-ั„ัƒะฝะบั†ะธั". I see that there's a lot of space surrounding the delta, so I edit the object and remove default 0.2cm spacing setting it to 0. But some space is still left inside the formula frame.
This is demonstrated in test document.
Comment 1 Owen Genat (retired) 2013-06-10 06:25:13 UTC
I don't think a single character is ever going to be a good candidate for a formula frame (or any frame really). I appreciate that you are trying to write ๐›ฟ-function (in Cyrillic script) but why not just use the Mathematical Italic Small Delta (U+1D6FF) as show here and in your description? This would seem to be the appropriate (text) form of use, as delta by itself is not really a formula.

Do you have a better example where a formula needs to be set in close contact with text?
Comment 2 Owen Genat (retired) 2013-06-10 07:31:38 UTC
This would also appear to be a duplicate of bug #65067.
Comment 3 Ruslan Kabatsayev 2013-06-10 07:45:52 UTC
(In reply to comment #1)
> I don't think a single character is ever going to be a good candidate for a
> formula frame (or any frame really). I appreciate that you are trying to
> write ๐›ฟ-function (in Cyrillic script) but why not just use the Mathematical
> Italic Small Delta (U+1D6FF) as show here and in your description? This
> would seem to be the appropriate (text) form of use, as delta by itself is
> not really a formula.
Well. It seems you consider anything what can be typeset with Unicode to be not a formula. But:
1. Searching character map (or learning unicode numbers by heart) is counter-productive when you could get your task done by using equation editor.
2. Even fractions and multiple powers can be typeset without equation editor, but why would one bother when there exists an equation editor?
3. What if you get a Word document which has such equations (which do work correctly in Word), and you have to open it with LibO?
 
> Do you have a better example where a formula needs to be set in close
> contact with text?
I'll have to think harder to find something which fits your demand, since fractions and powers also won't be good enough.
Comment 4 Ruslan Kabatsayev 2013-06-10 07:46:30 UTC
And yeah, this is a dup.

*** This bug has been marked as a duplicate of bug 65067 ***