Download it now!
Bug 65188 - RTF adds Indention to Tabstop
Summary: RTF adds Indention to Tabstop
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTF-Paragraph
  Show dependency treegraph
 
Reported: 2013-05-30 18:53 UTC by Guido
Modified: 2018-10-30 08:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Empty rtf document created with wordpad (1.83 KB, application/rtf)
2013-05-30 18:53 UTC, Guido
Details
Sample RTF-file with indentation (6.10 KB, application/msword)
2017-02-03 11:29 UTC, BS Dev-Team
Details
Sample RTF-file create with LibreOffice (5.47 KB, application/msword)
2017-02-03 11:38 UTC, BS Dev-Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guido 2013-05-30 18:53:56 UTC
Created attachment 80063 [details]
Empty rtf document created with wordpad

1. Open attached empty.rtf
2. Set indention to 1 
3. add tabstop to 3
4. Save document 
5. Reload document
expected: the document is as saved
current: the tabstop has moved to 4

If the indention is at 1.5 the tabstop moves to 4.5
You can reproduce the bug with a RTF from LO writer but you have to write and change the document twice.

Found in 4.0.3.3 and 3.6.4.3
Version 3.4.3 works fine
Comment 1 Jorendc 2013-05-31 11:32:39 UTC
I can reproduce this using Linux Mint 15 x64 with LibreOffice 4.0.3.3.

I'm going to mark this bug as Normal Medium:
* Medium: does prevent you to make high quality work
* Normal: default priority for medium bugs

@Miklos: ping :D

Kind regards,
Joren
Comment 2 A (Andy) 2015-04-06 17:13:03 UTC
Reproducible with LO 4.4.1.2, Win 8.1
Comment 3 tommy27 2016-04-16 07:26:46 UTC Comment hidden (obsolete)
Comment 4 BS Dev-Team 2017-02-03 11:29:59 UTC
Created attachment 130875 [details]
Sample RTF-file with indentation
Comment 5 BS Dev-Team 2017-02-03 11:38:23 UTC
Created attachment 130876 [details]
Sample RTF-file create with LibreOffice
Comment 6 BS Dev-Team 2017-02-03 12:00:29 UTC
We could reproduce this problem with the most recent LibreOffie Versions (see below for the conrete versions).

To reproduce:
* open attached Sample RTF-file with indentation.rtf (identation of the right part is correct)
* modify one character and "Save File as ..." somewhere
* close LibreOffice
* reopen saved file -> right part of the document has wrong identation (as shown in attached  Sample RTF-file create with LibreOffice.rtf)

We would highly appreciate a fix for this problem. Thanks!

Reproducable in:
Version: 5.2.5.1 
CPU-Threads: 8; BS-Version: Windows 6.2; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: group

and

Version: 5.3.0.3
CPU-Threads: 8; BS-Version: Windows 6.2; UI-Render: GL; Layout-Engine: neu; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 7 QA Administrators 2018-10-23 02:50:30 UTC Comment hidden (obsolete)
Comment 8 BS Dev-Team 2018-10-30 08:59:37 UTC
We could not reproduce this Bug using latest LibreOffice version!

Version: 6.1.2.1 (x64)
CPU-Threads: 8; BS: Windows 10.0; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: CL