Download it now!
Bug 65216 - Base crashes without trace on closing a dialogue and opening a new form
Summary: Base crashes without trace on closing a dialogue and opening a new form
Status: RESOLVED DUPLICATE of bug 65653
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta1
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-31 15:52 UTC by tim
Modified: 2013-06-15 11:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test odb file - see run instructions above (65.34 KB, application/vnd.oasis.opendocument.base)
2013-05-31 15:52 UTC, tim
Details
console + bt with symbols on master sources (10.98 KB, text/plain)
2013-05-31 21:12 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tim 2013-05-31 15:52:19 UTC
Created attachment 80100 [details]
Test odb file - see run instructions above

On an Intel 32bit Linux Mint Debian laptop with:

Libreoffice Base 4.1.0.0 beta1:
  pull time > 2013-05-30 00:40:10
  core:f73f1d2ecbe5629ded2bc840fb9b9bd5ec86fe01

The attached TestDb.odb (which needs Basic macros enabled) crashes as follows:

On opening, a form will appear.  
1) Hit 'List'
2) In the dialogue that then appears type 'Pa' in the 'Name' field
3) Hit 'Filter'
4) A form briefly appears and then Base crashes

This sample is an extract from a much fuller system which uses a Mysql back end.  I managed to port enough to the embedded platform to make this demonstration.  There are loads of badly written macros left in which have nothing to do with the problem.

This odb works fine on (amd) ubuntu 12.04 64 bit libreoffice 3.6.5, and on (intel) 32 bit mint debian libreoffice 3.5.4.

It's been a bit of a struggle to produce this.  I have reason to suppose it is related to #65045.  At one point when I made a minor edit to this odb that fault re-appeared.
Comment 1 Julien Nabet 2013-05-31 20:49:36 UTC
Comment on attachment 80100 [details]
Test odb file - see run instructions above

Mimetype fixed
Comment 2 Julien Nabet 2013-05-31 21:12:33 UTC
Created attachment 80105 [details]
console + bt with symbols on master sources

On pc Debian x86-64 with master sources updated today + brand new LO profile (and medium security for Macro), I reproduced the problem.
I attached bt
Comment 3 Tamás Zolnai 2013-06-15 11:39:41 UTC

*** This bug has been marked as a duplicate of bug 65653 ***